none
Files not showing on OSDisk

    Question

  • Hello,

    I've been trying to attach a new disk to my Ubuntu 14.04 VM. I think I made a mistake when I was editing the FSTAB. After rebooting the VM I was not able to SSH to the VM. Tried and researched but with no luck.

    I decided to create a new VM and attach the old OS disk to the VM to copy my files from it. However, after attaching the disk I can see my disk is empty with only "lost+found" folder.

    Do I have any option to recover the data on the OS disk :( ?

    Can Azure storage team recover the Disk or the container ?

    Thanks,

    Saed

    Friday, July 15, 2016 4:20 PM

All replies

  • Hi,

    Thank you for posting here!

    To Recover Azure VM by attaching OS disk to another Azure VM it is recommended that you first backup the problem VM’s OS disk and data disk as a precautionary step. You can use one of the available Azure Storage Explorer tools such as Microsoft Azure Storage Explorer, the AzCopy tool, or Azure PowerShell’s Start-AzureStorageBlobCopy cmdlet to create backups of the VHD files.

    Have you followed steps (check steps from 22 onwards) outlined in the below document to Recover Azure VM by attaching OS disk to another Azure VM?

    https://blogs.msdn.microsoft.com/mast/2014/11/20/recover-azure-vm-by-attaching-os-disk-to-another-azure-vm/

    If the issue still persists. I would request; You may open a support ticket with our technical team: 

    http://azure.microsoft.com/en-us/support/options/

    Regards,

    Vikranth S.

    Please remember to click "Mark as Answer" on the post that helps you, this can be beneficial to other community members reading the thread. And Vote as Helpful.

    Saturday, July 16, 2016 12:21 PM
    Moderator