locked
Unable to connect RRS feed

  • Question

  • User390265149 posted

    I am using Visual Studio 10 on Windows 7.

    I created a web application and build and published successfully and running successfully in browser from Visual Studio 10 (Web Developer).

    (a)  -  I have source code in 'E:\bkpl\intranetweb' having start file 'default.aspx'.

    (b)  -  I have pre-compiled code in 'E:\Users\USER\Documents\Visual Studio 2010\Projects\intranetweb (2)\PrecompiledWeb\intranetweb'

    Now I have created Virtual Directory with (a) and named it 'bkpl' and enabled Directory Browsing.

                It gives error 'Unable to connect' while clicking on 'Browse *:80 (http)' in Action pane of IIS Manager.

    Again I have created Virtual Directory with (b) and named it 'bkpl' and enabled Directory Browsing. (Before doing this, I deleted previously created virtual directory 'bkpl')

                It gives error 'Unable to connect' while clicking on 'Browse *:80 (http)' in Action pane of IIS Manager.

    I want my web application to run in browser either in server or in client.

    Friday, July 22, 2016 5:45 AM

Answers

  • User-166373564 posted

    Hi,

    Now I am getting error 'HTTP Error 404.17 - Not Found'

    To resolve this issue, configure the Application Pool hosting the application to meet all of the pre-conditions set for the Handler.

    1. Open the IIS Manager
    2. Expand the computer name and click "Application Pools" in the left pane.
    3. Highlight the Application Pool hosting the resource in the middle pane.
    4. In the far right pane click "Advanced Settings..."
    5. In the Advanced settings dialog under the category "(General)", configure the following settings to match the handler requirements:
      • .NET Framework Version
      • Enable 32-Bit Applications
      • Managed Pipeline Mode

    Reference: https://support.microsoft.com/en-us/kb/2019689 

    Regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 3, 2016 2:01 AM

All replies

  • User1242245693 posted

    hi,

    Can u please change the PORT 80 to 8080 , might so other application already working on 80.

    Friday, July 22, 2016 5:55 AM
  • User390265149 posted

    I don't understand this.

    I am clicking on 'Browse *:80 (http)' in Action pane of  'IIS Manager' and getting following error.

    'HTTP Error 404.3 - Not Found'

    After a lot of googling, I found that the following reason may be. But I don't know how to remove these error.

    • The handler mapping for the requested file name extension is not configured.
    • The appropriate MIME type is not configured for the Web site or for the application.

    If I run the program from VS 2010 directly, it runs perfectly.

    If I type the code 'http://localhost:49186/intranetweb/Default.aspx' it also runs perfectly.

    But how can I run this program without opening VS 2010?

    Friday, July 22, 2016 1:57 PM
  • User-166373564 posted

    Hi,

    'HTTP Error 404.3 - Not Found'

    To resolve this problem, follow these steps:

    1. Configure a handler mapping for the requested file name extension. To do this, follow these steps:
      1. Click Start, type inetmgr in the Start Search box, and then click Inetmgr in the Programs list.
        If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
      2. In IIS Manager, expand the server, expand Web sites, and then click the Web site that you want to modify.
      3. In Features View, double-click Handler Mappings.
      4. Configure an appropriate handler mapping for the type of the requested file name extension.
    2. Configure an appropriate MIME type for the Web site. To do this, follow these steps:
      1. Click Start, type inetmgr in the Start Search box, and then click Inetmgr in the Programs list. 
        If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
      2. In IIS Manager, expand the server, expand Web sites, and then click the Web site that you want to modify.
      3. In Features View, double-click MIME Types.
      4. In the Action pane, click Add.
      5. Add the extension of the required file  and the MIME type in the Add MIME Type box, and then click OK.

    But how can I run this program without opening VS 2010?

    No.

    Best regards,

    Angie

    Saturday, July 23, 2016 5:11 AM
  • User390265149 posted

    Hi sir

    I don't know

    1) What handler mapping should I fix.

    2) What MIME setting should I fix.

    Saturday, July 23, 2016 6:22 AM
  • User390265149 posted

    I found that this problem was due to my ASP.Net 2.0 version where as my attribute was targetFramework4.0. So I had to upgrade to ASP.Net 4.0

    Now I have move 1 step up. I removed 2 errors by upgrading ASP.Net 2.0 to ASP.Net 4.0

    I did following ways to upgrade to ASP.Net 4.0

    First make sure you have IIS installed then perform the following steps:

    1. Open your command prompt (<kbd>Windows</kbd> + <kbd>R</kbd>) and type cmd and press <kbd>ENTER</kbd>
      <sup>You may need to start this as an administrator if you have UAC enabled.
      To do so, locate the exe (usually you can start typing with Start Menu open), right click and select "Run as Administrator"</sup>
    2. Type cd C:\Windows\Microsoft.NET\Framework\v4.0.30319\ and press <kbd>ENTER</kbd>.
    3. Type aspnet_regiis.exe -ir and press <kbd>ENTER</kbd> again.
      • If this is a fresh version of IIS (no other sites running on it) or you're not worried about the hosted sites breaking with a framework change you can use -i instead of -ir. This will change their AppPools for you and steps 5-on shouldn't be necessary.
      • at this point you will see it begin working on installing .NET's framework in to IIS for you
    4. Close the DOS prompt, re-open your start menu and right click Computer and select Manage
    5. Expand the left-hand side (Services and Applications) and select Internet Information Services
      • You'll now have a new applet within the content window exclusively for IIS.
    6. Expand out your computer and locate the Application Pools node, and select it. (You should now see ASP.NET v4.0 listed)
    7. Expand out your Sites node and locate the site you want to modify (select it)
    8. To the right you'll notice Basic Settings... just below the Edit Site text. Click this, and a new window should appear
    9. Select the .NET 4 AppPool using the <kbd>Select...</kbd> button and click ok.
    10. Restart the site, and you should be good-to-go.

    Now I am getting error 'HTTP Error 404.17 - Not Found'

    Saturday, July 23, 2016 12:25 PM
  • User390265149 posted

    I solved this problem by opening IIS.

    Gone to my websites.

    Selected Handler Mapping.

    Searched for staticHandler

    In the Action pane, I selected revert to Parent.

    Now it is running program on other machine too.

    Unfortunately, only Mozilla Firefox supports.

    This program opens in Internet Explorer but without flash movie (converted from powerpoint).

    Google Chrome gives following error ->

    'This site can’t be reached

    The webpage at http://192.168.1.4:65535/Myapp/Default.aspx might be temporarily down or it may have moved permanently to a new web address.'

    What will be the solution?

    Saturday, July 23, 2016 3:14 PM
  • User-166373564 posted

    Hi,

    Now I am getting error 'HTTP Error 404.17 - Not Found'

    To resolve this issue, configure the Application Pool hosting the application to meet all of the pre-conditions set for the Handler.

    1. Open the IIS Manager
    2. Expand the computer name and click "Application Pools" in the left pane.
    3. Highlight the Application Pool hosting the resource in the middle pane.
    4. In the far right pane click "Advanced Settings..."
    5. In the Advanced settings dialog under the category "(General)", configure the following settings to match the handler requirements:
      • .NET Framework Version
      • Enable 32-Bit Applications
      • Managed Pipeline Mode

    Reference: https://support.microsoft.com/en-us/kb/2019689 

    Regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, August 3, 2016 2:01 AM