locked
increase time for login session RRS feed

  • Question

  • User-1481032724 posted

    hi for all

    i have website used membership security ;every account have page to add some information for each user;all user are slowly data entry when there added information press on add button .

    problem : when there typing data them need to 2 hour within it website end session for every user

    please how can i increase time for session

    Note :i added this code to config file

        <sessionState timeout="7200" />

    Sunday, December 28, 2014 4:11 AM

Answers

All replies

  • User-821857111 posted

    If you are using forms authentication, it's not session timeout that needs to be increased, it's forms timeout:

    <system.web>
        <authentication mode="Forms">
              <forms timeout="120"/> <!-- in minutes -->
        </authentication>
    </system.web>

    http://weblogs.asp.net/scottgu/430011

    Sunday, December 28, 2014 4:24 AM
  • User-1481032724 posted

    i added this code but problem nothing do:

     <httpRuntime maxRequestLength="2097151" executionTimeout="7200"/>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        </httpModules>
        <authentication mode="Forms">
          <forms name=".ASPXAUTH" loginUrl="/login.aspx" protection="All" timeout="120" path="/" requireSSL="false" slidingExpiration="true" cookieless="UseDeviceProfile" enableCrossAppRedirects="false"/>
        </authentication>

    Sunday, December 28, 2014 7:07 AM
  • User-1199946673 posted

    If you are using forms authentication, it's not session timeout that needs to be increased, it's forms timeout:

    Yes, but by setting the timeout to 120, it means that the authentication ticket will expire anywhere between 60 to 120 minutes after the last request. When they need at least 120 minutes, the timeout needs to be set to 240

    Also, when it's still not working and users are redirected to the login page much sooner, set a machinekey in your web.config

    Sunday, December 28, 2014 11:15 AM
  • User-1151753377 posted

    Hi tareq.tareq,

    Thank you for your post.

    Maybe you could change the following time-outs in Internet Services Manager just @kalyan1982  as said in the link below.

    http://forums.asp.net/t/1283350.aspx?How+to+increase+session+timeout+to+8+to+9hrs+

    Best Regards,

    Summer

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 5, 2015 12:46 AM