locked
How do I change the framework language RRS feed

  • Question

  • Hi,

    I have a new computer with vista on-board. The OS language is Polish and such is the locale of my framework. I have installed Visual Web Developer 2005 Express and Visual C# 2005 Express and telling the truth I did not see the state before installing so I don't know which frameworks got installed among the studio (perhaps all the frameworks have already been preinstalled??).

    Anyway - the OS language is Polish and the framework also reports everything in this language (including the compiler messages Surprise) what I don't accept. The question is how to change the labguage to english what is my absolute preferrence.

    What I see in my \Windows\Microsoft.NET\Framework directory is that I have the following versions there:

    1) v1.0.3705
    2) v1.1.4322
    3) v2.0.50727
    4) v3.0

    In 2) and 3) there is a subdirectory "pl" which I suppose is the installation folder of language pack.

    Although the VWD language is English, the framework reports in Polish. Please help me. Thanx in advance Smile
    Monday, June 18, 2007 7:44 PM

Answers

  • Hello Roland. Chances are very good that this is due to the Language setting under Tools/Options, Environment/International Settings. If this setting has changed from the default of 'English' to 'Same as Microsoft Windows', then these environments will attempt to load resources in the OS language first. Since your system language is Polish, you would see Polish .NET Framework messages, even inside the IDE.

     

    If this is indeed the case, then changing the setting to 'English' should correct the behavior.

     

    Cheers,

    Garrett

    Wednesday, June 20, 2007 9:51 PM

All replies

  • Hello Roland. Chances are very good that this is due to the Language setting under Tools/Options, Environment/International Settings. If this setting has changed from the default of 'English' to 'Same as Microsoft Windows', then these environments will attempt to load resources in the OS language first. Since your system language is Polish, you would see Polish .NET Framework messages, even inside the IDE.

     

    If this is indeed the case, then changing the setting to 'English' should correct the behavior.

     

    Cheers,

    Garrett

    Wednesday, June 20, 2007 9:51 PM
  • Hi,

    [Thanks for yor reply. Sorry for no response for so long but I've missed this issue - too much work  ]

    I've just checked and unfortunately the settings are correct - they say to use English... I will check language packs if I find the time. Will certainly publish the result to let you (and others maybe) know...




    Sunday, July 8, 2007 5:59 PM
  •  

    Hi,

    I see English but all error messages are in my own language. So i can't find solution when i don't get the error in English. Sad  Is there any way?

    Friday, May 2, 2008 1:17 PM