none
Remove Server Issue: Cannot Delete Folders, Only Contents RRS feed

  • Question

  • I moved our website a couple of years ago from FrontPage to Expression Web 4. To this day, I cannot completely delete a folder from the remote website files (right side of EW pane). I can delete the contents but not the folder itself. I used to be able to open FrontPage and delete the entire folder from the remote website but can no longer do this. Can anyone help me out with this? 
    Friday, September 26, 2014 7:25 PM

Answers

  • Scott, just FYI, I have no trouble, via EW4's FTP, deleting a folder and all its contents simply by deleting the folder. So empty or not may not be the issue, although it's certainly worth trying.

    Regardless, if this concerns folders created prior to using EW, not folders uploaded via EW, checking the permissions on the host via the site's hosting control panel might offer an explanation.


    • Edited by KathyW2 Saturday, September 27, 2014 4:39 AM
    • Marked as answer by BuyAFarm Monday, September 29, 2014 2:17 PM
    Saturday, September 27, 2014 4:39 AM

All replies

  • Are you publishing via FTP or still using the old FrontPageServer Extensions?

    I have no problems deleting folders from the server using EW.  I publish via FTP, and never used FPSE's on these sites, which means there were no folder permissions left over from old FPSEs, in case that matters.


    • Edited by KathyW2 Friday, September 26, 2014 8:54 PM
    Friday, September 26, 2014 8:53 PM
  • I could be mistaken, because I've never used FPSE since 2000, but I believe that EW hides "_vti" files and folders from view. So, even though you may think you've emptied a remote folder completely so that you can delete it, there may be hidden file(s)/folder(s) remaining in an apparently empty folder. Try opening the remote site using a 3rd-party client like the free FileZilla (which doesn't treat those folders any differently than any others) then checking for "_vti" files or folders in that client. Delete them all (AFAIK, EW only uses them on the remote if you're using the FPSE), then try deleting the folders you failed on before.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Saturday, September 27, 2014 3:07 AM
  • Scott, just FYI, I have no trouble, via EW4's FTP, deleting a folder and all its contents simply by deleting the folder. So empty or not may not be the issue, although it's certainly worth trying.

    Regardless, if this concerns folders created prior to using EW, not folders uploaded via EW, checking the permissions on the host via the site's hosting control panel might offer an explanation.


    • Edited by KathyW2 Saturday, September 27, 2014 4:39 AM
    • Marked as answer by BuyAFarm Monday, September 29, 2014 2:17 PM
    Saturday, September 27, 2014 4:39 AM
  • Sounds like it might be a server setting issue or an EW issue if EW or the server is trying to send them to "Your" recycle bin.
    Because you can't delete a file or folder across domains.


    Expression Web MVP

    Saturday, September 27, 2014 11:21 PM
  • KathyW2: I am publishing via FTP. How would I check to see if I folder permissions left over from old FBSEs? Or, does publishing via FTP automatically delete these permissions? And, thank you for replying. I really appreciate it.
    Monday, September 29, 2014 1:12 PM
  • Thank you Kathy! I went to my host site and took a look on hosting control panel and was able to delete the folders/files directly. Again, thank you for pointing me in the right direction!
    Monday, September 29, 2014 2:18 PM