locked
Package Management NPM Upstream stopped working following Update 2 install RRS feed

  • Question

  • Hi

    We have upgraded TFS to 2017 Update 2 and the NPM upstream feed capability has stopped working. It was working fine prior to the upgrade.

    Now when we try to install a package that is not in already in our feed we get the following error;

    0 info it worked if it ends with ok
    1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
    1 verbose cli   'C:\\Users\\jfh\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js',
    1 verbose cli   'install',
    1 verbose cli   'caniuse-db@1.0.30000712',
    1 verbose cli   '-g' ]
    2 info using npm@5.3.0
    3 info using node@v7.7.4
    4 verbose npm-session 3bad5549b31c3109
    5 silly install loadCurrentTree
    6 silly install readGlobalPackageData
    7 http fetch GET 200 http://maplestfs:8080/tfs/Maples/_packaging/SharedNpm/npm/registry/caniuse-db 2079ms
    8 silly fetchPackageMetaData error for caniuse-db@1.0.30000712 request to https://registry.npmjs.org/caniuse-db/-/caniuse-db-1.0.30000712.tgz failed, reason: unable to get local issuer certificate
    9 verbose type system
    10 verbose stack FetchError: request to https://registry.npmjs.org/caniuse-db/-/caniuse-db-1.0.30000712.tgz failed, reason: unable to get local issuer certificate
    10 verbose stack     at ClientRequest.req.on.err (C:\Users\jfh\AppData\Roaming\npm\node_modules\npm\node_modules\pacote\node_modules\make-fetch-happen\node_modules\node-fetch-npm\src\index.js:68:14)
    10 verbose stack     at emitOne (events.js:96:13)
    10 verbose stack     at ClientRequest.emit (events.js:191:7)
    10 verbose stack     at TLSSocket.socketErrorListener (_http_client.js:358:9)
    10 verbose stack     at emitOne (events.js:96:13)
    10 verbose stack     at TLSSocket.emit (events.js:191:7)
    10 verbose stack     at emitErrorNT (net.js:1289:8)
    10 verbose stack     at _combinedTickCallback (internal/process/next_tick.js:80:11)
    10 verbose stack     at process._tickCallback (internal/process/next_tick.js:104:9)
    11 verbose cwd C:\Users\jfh\Desktop\Test
    12 verbose Windows_NT 10.0.14393
    13 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\jfh\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install" "caniuse-db@1.0.30000712" "-g"
    14 verbose node v7.7.4
    15 verbose npm  v5.3.0
    16 error code UNABLE_TO_GET_ISSUER_CERT_LOCALLY
    17 error errno UNABLE_TO_GET_ISSUER_CERT_LOCALLY
    18 error request to https://registry.npmjs.org/caniuse-db/-/caniuse-db-1.0.30000712.tgz failed, reason: unable to get local issuer certificate
    19 verbose exit [ 1, true ]

    Thanks

    Jared


    Monday, August 7, 2017 9:44 PM

Answers

  • Hi I managed to resolve the issue with upstream caching. Not exactly sure how, but it was most likely one of the following; 1 - Rebooting the application servers 2 - Adding the TFS admin service account to local admins 3 - Logging in with the TFS admin account 4 - Setting the admin accounts proxy server via ie. The same setting as already in web.config. Anyway, problem solved for now. Thanks Jared
    • Marked as answer by JaredFHolgate Tuesday, August 8, 2017 12:14 PM
    Tuesday, August 8, 2017 12:13 PM

All replies

  • Hi Jared,

    Do you mean you have removed a version of an npm package from a feed as you mentioned you tried to install a package that is not in already in your feed?

    Have you unpublished the package as the article below:

    https://www.visualstudio.com/en-us/docs/package/npm/deprecate-unpublish

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, August 8, 2017 10:31 AM
  • Hi I managed to resolve the issue with upstream caching. Not exactly sure how, but it was most likely one of the following; 1 - Rebooting the application servers 2 - Adding the TFS admin service account to local admins 3 - Logging in with the TFS admin account 4 - Setting the admin accounts proxy server via ie. The same setting as already in web.config. Anyway, problem solved for now. Thanks Jared
    • Marked as answer by JaredFHolgate Tuesday, August 8, 2017 12:14 PM
    Tuesday, August 8, 2017 12:13 PM