locked
about the paging in rdlc RRS feed

  • Question

  • User-86041214 posted

    Hi:

    I meet an problem about the pagation in rdlc. I use reportview10.0, and after 

    setting the table and its dataset in rdlc. When using the rdlc to get the 

    report, the data is all in 1 page, however, if save the data to pdf or print, 

    the total page will be 3. 

    That means its doesn't paging at initial page, and that's very strange. 

    Is there any setting I need to set, or some other problem case that.

    (my cells will include some data in multiline style)

    Monday, February 17, 2014 3:57 AM

Answers

  • User1140095199 posted

    Hi,

    abramhum.c.l

    Because one page need more than one item, and it need to be dynamically. 

    Is there any other more improved methody. Thanks a lot.

    I feel if that doesn't resolve the issue it is better to create a report dynamically and set the number of records in each page.

    OR change the Parameter as per the Desired Number of Records needed.

    Expression =Ceiling(RowNumber(Nothing)/1)

    Change the Value to Nothing/2 or Nothing/3. To set the number of records needed per page.

    Best Regards!

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 25, 2014 9:04 PM

All replies

  • User309602797 posted

    I resolved this issue set the property PageCountMode=Actual on the Report viewer control.

    Monday, February 17, 2014 4:35 AM
  • User-86041214 posted

    Still not working. It's really strange and does any other method to cover that, 

    Thanks a lot.

    Wednesday, February 19, 2014 3:16 AM
  • User1140095199 posted

    Hi,

    report, the data is all in 1 page, however, if save the data to pdf or print, 

    To determine records per page or to display one Record in each Page. You need to follow the following steps;

               1. Drag and Drop a List to the Report Body.

               2. You need to create a group base on your Key value or any other value you feel suitable.

               3. When asked for Group by clause set the expression

        =Ceiling(RowNumber(Nothing)/1)

              This is a mathematical expression you have to set the value as per your need. For Example if you have 1000 Rows and you want to display just 10 rows per

              page divide it by 100. This will give you 10 rows per page

             =Ceiling(RowNumber(Nothing)/100)

              4. Go to the   -> Group Properties window  -> PageBreaks Tab -> In the Set page break options

             check Between each instance of the group

      

    In your case Use the Expression =Ceiling(RowNumber(Nothing)/1)

    Hope it Helps!

    Best Regards!

     

     

     

    Wednesday, February 19, 2014 3:42 AM
  • User-86041214 posted

    Hi, I following the upper steps and find the strange result, I get each page for one item; 

    however, it indeed make the data in UI represented as save to pdf, however, still not 

    suitable. Because one page need more than one item, and it need to be dynamically. 

    Is there any other more improved methody. Thanks a lot.

    Wednesday, February 19, 2014 8:29 PM
  • User1140095199 posted

    Hi,

    abramhum.c.l

    Because one page need more than one item, and it need to be dynamically. 

    Is there any other more improved methody. Thanks a lot.

    I feel if that doesn't resolve the issue it is better to create a report dynamically and set the number of records in each page.

    OR change the Parameter as per the Desired Number of Records needed.

    Expression =Ceiling(RowNumber(Nothing)/1)

    Change the Value to Nothing/2 or Nothing/3. To set the number of records needed per page.

    Best Regards!

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 25, 2014 9:04 PM