none
BizTalk Dynamics Ax adapter - Connection problem RRS feed

  • Question

  • Hi.

    I have a BizTalk server in one domain, and the AOS server in another. The aos server is set up as described in the installation manual, but I am having connection problems, when I try to extract schemas using the wizard in visual studio. I can't seem to find a place to specify the user creditentials to connect to the AOS....

    Anyone have any experience setting up the BizTalk adapter for dynamics, when the two servers are in different domains? I am using BizTalk server 2010 and Dynamics 2009.

    Best regards

    Peter


    Friday, July 15, 2011 8:18 AM

Answers

  • Hi Peter,

    Log into AX.

    Go to Basic-> Setup -> Application Integration Framework -> Services

    Find and select the AIF service you need XSD schemas for. Press the button “Service Operations”

    Select the needed “Service Action” (read, create, update, delete, find …) and press the button “Parameter Schema”. Select “View schema” and save the XSD schema to file.

    Best regards.

    Rasmus Jaeger

     

    Monday, July 18, 2011 8:42 AM

All replies

  • Hi Peter,

    The wizard uses the user credentials from Visual Studio. Use the cmd command “runas” to start your Visual Studio with the correct credentials.

    Cmd

    runas /user:user@domain.microsoft.com "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe"

    Best regards

    Rasmus Jaeger

    Friday, July 15, 2011 9:04 AM
  • Thank you for your reply.

    But i can't seem to run VS as a user from a different domain...

    Friday, July 15, 2011 11:35 AM
  • Hi Peter,

    Log into AX.

    Go to Basic-> Setup -> Application Integration Framework -> Services

    Find and select the AIF service you need XSD schemas for. Press the button “Service Operations”

    Select the needed “Service Action” (read, create, update, delete, find …) and press the button “Parameter Schema”. Select “View schema” and save the XSD schema to file.

    Best regards.

    Rasmus Jaeger

     

    Monday, July 18, 2011 8:42 AM