none
SSL Provider, error An existing connection was forcibly closed by the remote host. RRS feed

  • Question

  • We are getting following error : A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

    We have TCP/Ip and Shared Memory enabled, Login has sysadmin privileges, we can ping to server, we can connect through SSMS also.

    We have sql server 2012 and sql service account using. This is in Redgate inventory Monitor but we can connect to Sql server using SSMS and also ping to server. Somehow following error getting we see the DB instance is down and trying to test the connection, previously we didn't getting this issue.

    Friday, October 11, 2019 1:32 AM

All replies

  • Hi pdsqsql,

    Please start your SQL server service. Please make sure SQL server browser is running and SQL Server is configured to allow remote connections. Please check your SSL and TLS settings. The settings between the client and server should be somewhat consistent (i.e. if the server only allows 1.2 and the client only supports 1.0). Please refer to this document. Please Also read through the known issues on that page. 

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, October 14, 2019 9:34 AM
  • Thanks Cathy for your response.

    1) I restarted all sql server services

    2) SQL server browser is running and SQL Server is configured to allow remote connections.

    3) How can i check SSL and TSL settings?

    4) We have .Net above 4.5 version

    5) IT's sql Server 2012

    Wednesday, October 16, 2019 3:17 AM
  • Hi pdsqsql,

    >>How can i check SSL and TSL settings?

    You can check it from registry setting.  

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, October 29, 2019 9:11 AM
  • Thanks Cathy.

    I have checked ,Net framework and it's 4.5.

    I was checking SSL and TLS on my both the server having same values.

    It's little strange that i can connect through SSMS and run any query but in Redgate inventory manager , connection shows down and getting connection error as listed above. My Test and Production server both having similar configuration and same version but test having connectivity issue error when trying to test instance connectivity through Redgate Inventory manager (not through SSMS or any other connection). but production instance doesn't have any issue. 

    Both have Sql server 2012 SP2 and login has same credentials.

    Thursday, October 31, 2019 2:34 AM
  • Any one has better idea?

    I tried on all kind of servers (2012, 2014, 2008R2) even both server test and production has same version, same features and on one server working fine but not working on other.

    Thanks

    Saturday, November 16, 2019 3:29 AM