locked
File Upload Error "Unable to complete this operation" RRS feed

  • Question

  • I have been banging my head on the wall over this all day and cannot find anything that has helped yet.  When going to upload a file above 300kb i get the
    Unable to complete this operation, please contact your administrator
    My client emailed me with this issue last night.  Everything has been working fun until this.  I have all of the upload settings maxed out,  there is plenty of space on the hard drive,  the files are not corrupt and the firewall is fine.  Does anyone have any ideas??
    Thursday, December 31, 2009 10:33 PM

Answers

  • Dear Timothy,

    You need to verify that the Content Database has "Unlimited" in maxsize and 10% in Growth.
    could you please read the following blog http://svengillis.blogspot.com/2008/06/uploading-error-unable-to-complete-this.html ?


    Best Regrads, Ahmed Madany
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:15 AM
    Friday, January 1, 2010 1:58 AM
  • The changes being discussed are SQL Server changes, not SharePoint changes.  You would do this by editing the database properties through the sql tools.  If you are using WSS with the Windows Internal Database then this may not be as easy since you cannot use the regular toolset.

    Which version of SharePoint are you using, and how is the SQL server setup?  When you checked the drive space, did you look on the SharePoint server or the SQL server.  Do you know where the data and logs are for the db?
    SharePoint MVP | Developer | Administrator | Speaker-- Twitter -- Blog - http://nextconnect.blogspot.com
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:16 AM
    Sunday, January 3, 2010 5:21 AM
  • Well I found the issue. The it database is running on sql 2005 express and has reached its 4gb limit. Need to see how the client feels about the $1k workgroup upgrade. Thank you all very much for your help. Sorry for my ignorance on the subject.
    • Proposed as answer by khimming Tuesday, January 5, 2010 5:58 AM
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:16 AM
    Sunday, January 3, 2010 6:31 PM

All replies

  • Dear Timothy,

    You need to verify that the Content Database has "Unlimited" in maxsize and 10% in Growth.
    could you please read the following blog http://svengillis.blogspot.com/2008/06/uploading-error-unable-to-complete-this.html ?


    Best Regrads, Ahmed Madany
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:15 AM
    Friday, January 1, 2010 1:58 AM
  • Thank you Ahmed.

    I read the article but it tells me no where how to do this.  I am new to the sharepoint world and haven't dabbled in data basing all that much.  I don't seem to see the option in the sharepoint admin console.  All help would be appreciated.  Thank you very much.
    Saturday, January 2, 2010 11:30 PM
  • The changes being discussed are SQL Server changes, not SharePoint changes.  You would do this by editing the database properties through the sql tools.  If you are using WSS with the Windows Internal Database then this may not be as easy since you cannot use the regular toolset.

    Which version of SharePoint are you using, and how is the SQL server setup?  When you checked the drive space, did you look on the SharePoint server or the SQL server.  Do you know where the data and logs are for the db?
    SharePoint MVP | Developer | Administrator | Speaker-- Twitter -- Blog - http://nextconnect.blogspot.com
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:16 AM
    Sunday, January 3, 2010 5:21 AM
  • Dear Timothy,

    firstly, chances are that the partition drive on the machine where your Content database is sitting has run out of space. Therefore, you will have to look for alternatives of increasing the free space otherwise relocate your SharePoint databases.

    if LDF and MDF files stored on the same partition, plz , delete this log file by detaching the database then clear log file then add the database to your application again with stsadm

    stsadm -o addcontentdb -url http://yourportal -databaseserver DBServer -databasename ContentDB .

    secondly, To check the size of the database , you use SQL Server Management studio to check the size of the database, then check the rate of the growth.
     
    Best Regrads, Ahmed Madany
    Sunday, January 3, 2010 1:56 PM
  • I'm not sure of the settings because I did not set this up.  There are 288gb of space left so I don't think that is an issue.  I haven't done a lot of db work so I am not that familiar with everything but I will do what I can.  Thank you for the assistance.
    Sunday, January 3, 2010 2:58 PM
  • OK, could you please  check the size of the database, then check the rate of the growth?

    in SQL 2005 go to database -> right click database -> select properities -> select files -> goto autogrowth , check enabling unrestricted growth.

    your issue totally associated with SQL Server. so, i suggest also checking  system drive because the machine itself is probably running out of space and if you have backup plan also check it and the location of backup.


    Best Regrads, Ahmed Madany
    Sunday, January 3, 2010 3:06 PM
  • all I have available to me is the sql server configuration manager.  I have 288 gb of free space on the drive.  Did there person who origionally set this up not install all  the management components?  I'm installing the managment studio express version right now.
    Sunday, January 3, 2010 5:44 PM
  • Well I found the issue. The it database is running on sql 2005 express and has reached its 4gb limit. Need to see how the client feels about the $1k workgroup upgrade. Thank you all very much for your help. Sorry for my ignorance on the subject.
    • Proposed as answer by khimming Tuesday, January 5, 2010 5:58 AM
    • Marked as answer by GuYuming Tuesday, January 5, 2010 7:16 AM
    Sunday, January 3, 2010 6:31 PM