none
nullEscape documentation not correct

    Question

  • I was trying to figure out how to use the nullEscape parameter with EXRACT.  In particular I wanted to use "\N" to represent nulls.   I kept getting a syntax error.  

    Per the documentation it is not clear how to do this.  https://msdn.microsoft.com/en-us/azure/data-lake-analytics/u-sql/extractor-parameters-u-sql

    I found after some digging that you need to specify escape the backslash character to get this to work:

        USING Extractors.Csv(nullEscape:"\\N");

    Perhaps the docs can be updated to specify that the value needs to be \\N instead of \N ?

    Thanks



    Tuesday, July 24, 2018 5:27 PM

All replies

  • Thanks for the feedback. I will send an email to the team to review the feedback and update the article as appropriate.
    Tuesday, July 24, 2018 7:09 PM
    Moderator
  • Thanks very much to David - his post helped me fix a problem I was having.

    It would help if the documentation of the U-SQL Extractors nullEscape parameter was fixed, I wasted hours on this problem before I found this post.

    Wednesday, November 28, 2018 6:32 PM