locked
WARNING: Android SDK Tools rev v24.3.4 RRS feed

  • Question

  • User73229 posted

    Hello,

    Google has released a new version of Android SDK Tools (rev. 24.3.4). This version breaks the Xamarin.Android designer.

    Update August 19: fix for Designer issue (Bug 33174) now available in the Stable channel

    The fix for the designer Bug 33174 has now been released to the Stable channel:

    If you still see Bug 33174 after updating, or if you find any additional bugs caused by Android SDK Tools (rev. 24.3.4), please file a bug report and add a comment back on this thread with the bug number. Thanks!

    Known issues with latest Stable (listed above)

    There are currently two known issues with the released builds. This post will be updated to reflect progress on these bugs, as updates are available

    Private bug 33236 - On starting Xamarin Android Player with Xamarin Studio, IP address of Xamarin Android Player emulator displays in device configuration dropdown.

    Private bug 33237 - Unable to start Xamarin Android Player emulator as it is displaying as an unsupported section in device list in VS.

    Error Message

    ERROR: java.lang.NoSuchMethodError: com.android.ide.common.rendering.api.HardwareConfig.<init>                  
    (IILcom/android/resources/Density;FFLcom/android/resources/ScreenSize;Lcom/android/resources/ScreenOrientation;Z)V
    

    Alternate workaround

    If you do not want to upgrade yet, the below workaround is still valid. However, if you at any point want to upgrade to Android SDK Tools 24.3.4, then you will need to upgrade to the versions listed above.

    Downgrade links

    Windows

    • https://dl-ssl.google.com/android/repository/tools_r24.3.3-windows.zip

    Mac

    • https://dl-ssl.google.com/android/repository/tools_r24.3.3-macosx.zip

    Downgrade steps

    1. Close ALL instances of Visual Studio and/or Xamarin Studio
    2. Locate the tools directory in the Android SDK path. One way to find the right directory is to open "Tools -> Open Android SDK Manager" in Xamarin Studio or "Tools -> Android -> Android SDK Manager" in Visual Studio. The tools subdirectory can be found within the "SDK Path" that is displayed at the top of the SDK Manager window.
    3. Delete the tools directory.
    4. Unzip the tools_r24.3.3*.zip file into the "SDK Path", creating a directory named "tools". Be careful not to create an extra outer "tools" directory when unzipping this file: the top-level "SDK path" should contain tools/android, not tools/tools/android.

    Bugzilla Link

    https://bugzilla.xamarin.com/show_bug.cgi?id=33174

    What to do if the workaround doesn't work

    Please post a screenshot of your SDK tools window. This is available via the following means:

    • Xamarin Studio : Tools >Open Android SDK Manager

    • Visual Studio : Tools > Android > Android SDK Manager

    A compliant Android SDK Manager will look similar to the following screenshot, where an update is available to 24.3.4, but not installed:

    Monday, August 17, 2015 10:36 PM

All replies

  • User150803 posted

    Downgrade did not work for me. More details here:

    http://forums.xamarin.com/discussion/48410/the-layout-could-not-be-loaded-not-bug-30556?new=1

    I literally installed Android SDK and Xamarin at 5 PM, didn't see this notice to use an older version.

    Also, your downgrade links are both for Mac OS X.

    Monday, August 17, 2015 11:51 PM
  • User73229 posted

    @chrismorris

    Thanks for the feedback. I will test a few scenarios to reproduce what you are seeing and will respond back shortly.

    Thanks again!

    Tuesday, August 18, 2015 12:00 AM
  • User150803 posted

    After completely uninstalling Xamarin and Android Studio, I reinstalled Android studio and Xamarin, opened Xamarin to confirm the SDK file path, then before opening up a new project, I replaced the tools folder, closed Xamarin, re-opened it, and now the Main.axml loads correctly. Not sure if this helps.

    Tuesday, August 18, 2015 1:58 AM
  • User147136 posted

    Thanks CodyB now it's working

    Tuesday, August 18, 2015 3:01 AM
  • User150751 posted

    I had the same issue. Before realizing the downgrade revision was 24.3.3 (and not 24.2 as I first thought the problem was similar to this one) I followed the steps suggested by chrismorris above, which did solve the problem, however a simple downgrade might have solved it.

    Thanks!

    Tuesday, August 18, 2015 9:32 AM
  • User123 posted

    Luckily the designer is pretty minimal.

    Tuesday, August 18, 2015 1:12 PM
  • User151247 posted

    Guys, SDK Tools version 24.3.3 is working fine as i can see the designer. Thanks for the workaround.

    Wednesday, August 19, 2015 5:08 AM
  • User148721 posted

    Thanx @CodyB , now the problem is solved.

    Wednesday, August 19, 2015 5:34 AM
  • User98542 posted

    work's for the moment

    Wednesday, August 19, 2015 12:22 PM
  • User114719 posted

    Fantastic it worked....I have downloaded 24.3.3 and replaced TOOLS folder and ran the VS and it worked...Great Thank you

    Wednesday, August 19, 2015 4:45 PM
  • User110191 posted

    Thanks, replacing the tools folder works for me

    Wednesday, August 19, 2015 6:04 PM
  • User151395 posted

    Thanks, downgrading works. Guess I decided to test out your product a couple days late, otherwise would not have got so frustrated because it didn't work off the bat. Good work getting the solution out so quick

    Wednesday, August 19, 2015 6:23 PM
  • User151492 posted

    Work great for me. Thanks! André

    Wednesday, August 19, 2015 7:13 PM
  • User93652 posted

    Layouts back, works for me too. Thanks

    Thursday, August 20, 2015 9:08 AM
  • User13783 posted

    Thanks Now It's Work Fine :smile:

    Thursday, August 20, 2015 1:20 PM
  • User4539 posted

    Version 3.11.837 is no more available for download?

    Friday, August 21, 2015 6:02 AM
  • User73229 posted

    @ozand

    The download link will take you to the latest version from our Xamarin Store, which includes the hotfix.

    Thanks

    Friday, August 21, 2015 6:05 AM
  • User4539 posted

    @CodyB thanks for quick reply but the latest version doesn't fix the issue for me (and the latest version is still the version 3.11.836 (ed5c750)).

    Friday, August 21, 2015 6:11 AM
  • User73229 posted

    @ozand

    From within your IDE are you able to check for Xamarin updates?

    Friday, August 21, 2015 6:22 AM
  • User4539 posted

    @CodyB update from within IDE worked fine (3.11.837 is now installed) and the designer is working now fine. Thanks

    Friday, August 21, 2015 6:33 AM
  • User136407 posted

    Since I upgraded from 5.94 to 5.95, the xamarin android player emulator has been hanging, it says 'waiting for Nexus 4 to start' but it never starts. ive downgraded to 5.94 and it still did not make a difference. I need help asap.

    Friday, August 21, 2015 10:16 AM
  • User151125 posted

    My SDK screen in Picture. Error is "the layout could not be loaded: the operation failed due to an internal error: com.adroid.ide.common.rendering.api.HardwareConfig.(IILcom/android/resources/Density;FFLcom/android/resources/ScreenSize;Lcom/android/resorces/ScreenOrientation;Z)V."

    How i can solve this problem? Your suggestions do not solve the problem.

    Friday, August 21, 2015 2:55 PM
  • User19404 posted

    even after rolling back to 24.3.3, xamarin studio can't connect to the xamarin android player if i launch the player from xamarin studio. if i manually launch the player, i can connect to it by selecting the IP address of the player in xamarin studio.

    Friday, August 21, 2015 4:36 PM
  • User136407 posted

    iv'e updated the sdk manager I cannot connect to the xamarin android player. please help asap.

    Friday, August 21, 2015 5:28 PM
  • User19404 posted

    launch xamarin android player manually, then select the player's ip address as the device you wish to connect to in xamarin studio.

    Friday, August 21, 2015 5:45 PM
  • User136407 posted

    thank you @leankitryan :smile:

    Saturday, August 22, 2015 3:25 AM
  • User145506 posted

    Hello,

    For those of you who use VS 2015 Enterprise (not sure if this will fix it on other versions): I had the same issue. Downgrading and only installing this update didn't work for me.

    My Solution was, to install the update, create a new Blanc-App-Project in Xamarin Studio(not in VS), and manually clicking threw the whole project and update things like "Xamarin.Forms" by rightclick->update. Make sure that there is a note which tells you if it is updateable (e.g. "Xamarin.Forms (24.8.69.5 update)". Restarting Xamarin Studio and Visual Studio after this steps solved my problem. (btw im running windows 10, not sure if this is relevant).

    Good luck!

    Saturday, August 22, 2015 3:49 PM
  • User55225 posted

    Hi @CodyB!

    Thanks for the post :)

    I am still having issues with the Debug button in VS and Unsupported Devices. (It's really slowing me down)

    I reverted my Android SDK as per above and below is my Android SDK screenshot

    Do you have any information or workaround for: Private bug 33237 - Unable to start Xamarin Android Player emulator as it is displaying as an unsupported section in device list in VS.

    Thanks!

    Monday, August 24, 2015 12:06 PM
  • User134477 posted

    Hi,

    after updating the Xamarin, Android Designer is not displaying the custom layout. Before the upgrade, the layout was displayed normally. Attached my layout files.

    Tuesday, August 25, 2015 1:10 AM
  • User117516 posted

    non of the above is working, still have the same issue ! starting to hate this xamarin thing . since i installed it its fixing issues that are not related to my code.

    Tuesday, August 25, 2015 6:09 AM
  • User75267 posted

    I'm also unable to use Xamarin Android Player from VS unfortunately. I tried doing the downgrade to the previous tools and still no dice. Had to switch to VS Android Emulator (which has come a long way) but would still like to be able to use XAP again at some point.

    Tuesday, August 25, 2015 9:09 PM
  • User153175 posted

    How do you get the latest version, when I run the install it tells me I have the latest version (but I don't).

    Tuesday, August 25, 2015 11:16 PM
  • User93000 posted

    Filed a new bug: Adding a switch to a layout causes the designer to throw an exception if targeting 5.1 with SDK 24.3.4. https://bugzilla.xamarin.com/show_bug.cgi?id=33389

    Wednesday, August 26, 2015 9:17 AM
  • User55600 posted

    This is happening to me as well. MacOS, Xamarin Studio. After this update, I was able to open/edit my layout, but upon then running my app, I'm left with this same "Starting _..." issue. Android Player starts. I can unlock the screen. I can even run the previous installation of my app. But it's as if Android Player is no longer notifying Xamarin Studio that it's loaded so that Studio can progress to the next step of installing and running my app. Someone, please help.

    Wednesday, August 26, 2015 11:55 PM
  • User55600 posted

    Trying the suggestion of @leankitryan to run Android Player manually and then selecting its IP address within Xamarin Studio is also failing for me. "Deployment failed. Architecture not supported." What is going on?? Someone needs to get this world put back together quickly. Or explain to us how we're all doing this the wrong way, and what the correct way is. I've gone a couple cycles of replacing the tools folder, updating SDK Tools through the SDK Manager, installing the latest build of Xamarin, rebooting, on and on and on. It's possible that I've created some disconnection of sorts that is now resulting in "Architecture not supported" since I don't see anyone else reporting that. Any help at all will be greatly appreciated.

    Thursday, August 27, 2015 12:04 AM
  • User96012 posted

    @CodyB thanks. First replace tools folder and then installed 3.11.837. Now designer is working fine.

    Thursday, August 27, 2015 8:52 AM
  • User149570 posted

    @twoo I'm experiencing the same issue. I've tried various things including reverting back to older SDK and Xamarin Android Player will still not launch properly (it's listed in Unsupported Devices)

    Friday, August 28, 2015 5:34 PM
  • User75267 posted

    @PeterB2015 - Same XAP VM's were always in unsupported devices. Tried all the suggestions and still no dice. I'd recommend just using regular devices or VS Android Emu until they get a new patch out.

    Friday, August 28, 2015 7:45 PM
  • User153392 posted

    I am using Visual studio 2015 and android sdk version 24.3.4, every time I try to open the Layout page it gives me an error as show in the attached snap shot. I had tried everything from reinstalling the package to downgrade the sdk to 24.3.3 Moreover when I downgrade the sdk and try to create a new project it gives object reference null error.

    Saturday, August 29, 2015 2:21 PM
  • User153392 posted

    Thanks Xamarin Team your solution really helped.

    Sunday, August 30, 2015 6:14 AM
  • User55225 posted

    @PeterB2015 @twoo and any others who have issue with XAP in unsupported device list. I also did the following.

    1. Replaced the Android SDK tools folder to 24.3.3 following instructions posted at the beginning of this post.

    2. Installed the latest jdk1.7.079 from the Java as per instructions at http://developer.xamarin.com/guides/android/gettingstarted/installation/windows/manual_installation/ and made sure that the VS JDK path in Tools->Options->Xamarin->Android->Java Development Kit Location is correct

    3. Uninstalled and installed the latest XAP from http://xamarin.com/android-player

    I'm not sure which did it, but I am not back seeing my running XAP in the VS device drop down list again. :smiley:

    Sunday, August 30, 2015 1:06 PM
  • User154069 posted

    I am using VS 2015 community,xamarin 5.9.5 and android SDK 24.3.4. I can able to build and deploy app but the layout is not rendering in VS. i tried to downgrade android SDk but latest SDK needed error msg throwed in VS IDE. What is the problem? how to resolve it?

    Monday, August 31, 2015 2:20 PM
  • User153186 posted

    For those of you unable to get this fixed by downgrading or simply downloading the hot fix:

    Step One: Remove All Android Components Including: 1.) Java SDK 2.) Android SDK/NDK 3.) Xamarin Studio / Installer 4.) All Temporary Files and User Files 5.) Android Studio, If Installed

    Restart your computer.

    Step Two: Reinstall Java SDK, Android SDK/NDK Acquire Xamarin Installer for 5.9.5.10 (Hot Fix Link) Allow Xamarin to check for updates, in my case it installed two.

    Restart Computer. Please note, this did not work until I restarted my laptop. I'm not sure what the cause was, but from the error log it appears to be a corruption of either the java SDK or the android SDK upon failure to properly shut down xamarin studio. I began having these problems when I did a hard shutdown (held my power button) while xamarin and visual studio were open. So keep that in mind.

    Hopefully this saves some people the three days of agony I endured :expressionless:

    Monday, August 31, 2015 7:09 PM
  • User79767 posted

    Did anyone find a solution to this issue ?

    Even after implementing the workaround in first post and downgrading. XAP devices show as unsupported ...

    Does anyone have a solution to this issue?

    It has disrupted my development completely and this should be resolved ASAP...

    Friday, September 4, 2015 3:51 PM
  • User79767 posted

    Switching to VS Android Emulator ...

    Monday, September 7, 2015 1:03 PM
  • User75267 posted

    I finally got Xamarin Android Player working again (and with v24.3.4). I have W10 x64 and VS2015 for those looking to do this.

    1. I uninstalled XAP as well as Virtual Box and deleted all the Host Only networks.
    2. I installed XAP again from the website (0.5.5 Beta should be the download, once it runs, it will download a patch to update to 0.5.6)
    3. Install the latest BETA version of Virtual Box (I have 5.0.3 now) over the old version that XAP installs (otherwise W10 will not be able to connect)
    4. Open XAP, download a VM, and name it without any spaces
    5. Hopefully when you launch the VM, it should work!
    Tuesday, September 8, 2015 6:29 PM
  • User156231 posted

    When you install VS2015, the latest version of Xamarin is not installed. Then when you install latest version of android sdk (24.3.4) Main.xaml says latest version of android sdk is not installed and that you need 24.3 or newer. Installing last version of xamarin solves the problem.

    Sunday, September 13, 2015 8:30 AM
  • User114696 posted

    This is an awful issue.

    I've been really up against a deadline so to work around the issue in VS, I renamed the XAP Instance I wanted to work with to its IP address and span it up. VS then detects the XAP instance as expected and allows me to debug on it.

    Friday, September 18, 2015 9:39 AM
  • User132833 posted

    I just rename the XAP instance without space. Then it magically appears in the device list.

    Tuesday, September 22, 2015 7:10 AM
  • User66025 posted

    The designer for android in Xamarin.Studio is not loading.

    It just showing an error message that layout is not loading.

    The layout could not be loaded : The operation failed due to an internal error: com.android.ide.common.rendering.api.HardwareConfig.(IILcom/android/resources/Density;FFLcom/android/resources/ScreenSize;Lcom/android/resources/ScreenOrientation;Z)V.

    _Error : _

    Saturday, October 17, 2015 12:12 PM
  • User168792 posted

    It looks like beginning to work. Thanks for help. Good sharing.

    Thursday, October 22, 2015 7:50 AM
  • User168792 posted

    It looks like ourcase beginning to work. Thanks for help. Good sharing.

    Friday, October 23, 2015 1:59 AM
  • User168792 posted

    It looks like ourcase beginning to work. Thanks for help. Good sharing.

    Friday, October 23, 2015 1:43 PM
  • User168792 posted

    It looks like ourcase beginning to work. Thanks for help. Good sharing.

    Friday, October 23, 2015 1:43 PM
  • User173263 posted

    I upgraded from 5.94 to 5.95, the xamarin android player emulator has been hanging, it says 'waiting for Nexus 4 to start' but it never starts. ive downgraded to 5.94 and it still did not make a difference.

    Friday, November 13, 2015 9:21 AM
  • User13824 posted

    Issues with the Xamarin Android Player Preview hanging would be a separate category of bugs compared to the Android designer issues discussed in this thread and also separate from the XAP naming issues discussed later in the thread. If you can reproduce the hang consistently please do file a bug against the Xamarin Android Player. Thanks!

    Tuesday, November 17, 2015 5:02 PM
  • User13824 posted

    To tie up this thread, as recorded in the last updates in the first post in the thread, the particular problem covered by this thread (that was caused by an incompatibility with Android SDK Tools rev 24.3.4) was resolved by the following Stable Channel releases:

    • Xamarin for Visual Studio 3.11.837

    • Xamarin Studio 5.9.5

    For similar issues in newer releases, check for the latest updates about new releases on http://releases.xamarin.com, and as always please do file a bug if you find a problem that is not yet resolved in the latest versions. Thanks!

    Tuesday, November 17, 2015 6:05 PM