locked
Trying to connect to remote Mac RRS feed

  • Question

  • User395164 posted

    I am trying to connect to my remote Mac. It says that connection finished but get an error on list that says: "a remote error occured on the connected Mac" on the log I get this error: System.NullReferenceException: Object reference not set to an instance of an object.at Xamarin.Messaging.Windows.ErrorsManager.<>cDisplayClass30.b0(IErrorItem item) in E:\A_work\963\s\src\Core\Xamarin.Messaging.Windows\ErrorsManager.cs:line 24at Clide.ErrorsManager.<>cDisplayClass70.b0(Object sender, EventArgs e) in E:\A_work\349\s\src\Clide.Core.Windows\Errors\ErrorsManager.cs:line 55at Microsoft.VisualStudio.Shell.Task.OnNavigate(EventArgs e)at Microsoft.VisualStudio.Shell.Task.Microsoft.VisualStudio.Shell.Interop.IVsTaskItem.NavigateTo()at Microsoft.VisualStudio.ErrorListPkg.Shims.ErrorListPackageEventProcessor.PreprocessNavigate(ITableEntryHandle entryHandle, TableEntryNavigateEventArgs e)at Microsoft.VisualStudio.Shell.TableControl.Implementation.TableControlEventManager.<>cDisplayClass400.b2(ITableControlEventProcessor p, ITableEntryHandle entry)at Microsoft.VisualStudio.Shell.TableControl.Implementation.TableControlEventManager.<>cDisplayClass601`1.b0()at Microsoft.VisualStudio.Text.Utilities.GuardedOperations.CallExtensionPoint(Object errorSource, Action call) --- End of stack trace from previous location where exception was thrown --- at Microsoft.VisualStudio.Telemetry.WindowsErrorReporting.WatsonReport.GetClrWatsonExceptionInfo(Exception exceptionObject)

    Any help with this?

    Thursday, June 25, 2020 8:08 AM

All replies

  • User369979 posted

    Is your Mac on the same internet as your Windows? This appears to be an IDE issue, try to raise issues here: https://developercommunity.visualstudio.com/spaces/41/index.html

    Friday, June 26, 2020 5:43 AM
  • User226160 posted

    @deondk Did you ever solve this, I'm having the same issue.

    Tuesday, March 30, 2021 5:00 PM
  • User226160 posted

    After several hours of trying various things, trashing my Xcode install and re-installing worked. I had already been on the latest version for a long time and had the Xcode Command Line tools installed, so I'm not sure what went wrong in the first place.

    Tuesday, March 30, 2021 7:55 PM
  • User395164 posted

    Hi @brader ,glad you could get it working. I see now that the storyboard is not working on windows visual studio and they say you should use xcode to open storyboard. How do I open the storyboard on windows machine from the MAC? How are you now using storyboard?

    Monday, April 12, 2021 7:21 AM