MSVCR110.dll Not Found RRS feed

  • Question

  • Dear MSDN Community,

    I have a rather pressing problem when I start Microsoft Visual Studio 2012 Express Edition. I get the following error upon launching VS:

    This Application has failed to start because MSVCR110.dll was not found. Re-installing the application may fix this problem.

    Upon finishing the installation I did notice 3 install errors, they were all SQL Related but I installed them anyway to no avail. Any help is much appreciated!

    Sincerely, Eric Karolchyk

    Saturday, September 22, 2012 3:59 PM


All replies

  • This file is part of the VC++ 2012 Runtime. reinstall the runtime to fix it.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, September 23, 2012 2:11 PM
  • Thank you very much. This solved the problem.

    EDIT: Scratch that

    Sunday, September 23, 2012 3:54 PM
  • I'm sorry Andre.Aiegler, but that in-fact did not fix the issue. Instead of MSVCR110.DLL not being found, I get the following message, for another library issue:

    "C:\Windows\System32\MSCVP110.DLL is either not designed to run on Windows or it contains and error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support."

    This happens every time I re-install VC++ Redist or VS 2012 Express. I've tried to find another copy on the web, but to no avail. If I could ask a favor, could someone supply me a copy of msvcp110.dll for Windows Vista+ x86 that would be much appreciated. For some reason I believe that the file simply won't write correctly via installer.

    Sunday, September 23, 2012 9:09 PM
  • So you try to install the Express on Vista? I doubt that this is possible. From what I know the 2012 Express only works on Windows 7 and 8.

    System Requirements
    Supported operating systems
    Windows 7 SP1 (x86 and x64)
    Windows 8 (x86 and x64)
    Windows Server 2008 R2 SP1 (x64)
    Windows Server 2012 (x64)

    Also, have you installed the 32Bit Version? The IDE is 32Bit so you need the 32Bit version.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, September 23, 2012 9:46 PM
  • This explains everything. The error message practically says it doesn't work. I also should have noticed the title of the Error Dialog, it was "Compatibility Error!"

    Thank you for your help. I'll just have to use 2010 for now.

    Sunday, September 23, 2012 11:31 PM
  • Tuesday, September 17, 2013 8:57 AM
  • vs2012 redist update 4 is not fixed. givces same "is missing". I had uninstalled the resdist earlier, and when I found this article, I reinstalled this later version.
    Wednesday, April 30, 2014 10:49 AM