none
BizTalk 2009 Oracle DB adapter RRS feed

  • Question

  • We are using BizTalk 2009 as one of the key technology for EAI. This current project involves a dozen of applications working on various platforms and technologies to work together.

    We are using Visual Studio 2008 SP1 as the IDE and would like to know does 2006 BizTalk Enterprise Adapter pack comes with Oracle DB adapter if so why I cannot get the bindings in VS 2010 for orchestration and other programability.

    Also is it necessary to buy Adapter Pack 2.0 to work with Oracle 9i. My requirement with Oracle DB 9i, is to select few rows from a table and get the results.

    Please Advice.

    Thanks.

    Monday, January 24, 2011 8:13 AM

Answers

  • Hi,

    If you are working with BizTalk Server 2006 than BizTalk Adapter Pack 2.0 will be of no use as this supports only BizTalk 2006 R2 and above. Older adapters (i.e. Adapters for Enterprise Applications) support DB Oracle version you want select rows from. This document can be useful for you. There is in this case no need for Adapter Pack, unless you requirements for interacting with OracleDB that is not supported with Adapters for Enterprise Applications but with Adapter Pack 2.0. If so than you will have to upgrade your platform to BizTalk 2006 R2 or above.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Monday, January 24, 2011 12:01 PM
    Moderator

All replies

  • Hi,

    It is odd you are using VS2010 as IDE for BizTalk 2006. I assume you mean BizTalk 2010, which comes with Adapter Pack that includes old (i.e. non-WCF) adapters (called BizTalk Adapters for Enterprise Applications). BizTalk Adapter Pack 2.0 is included in BizTalk Server 2009/2010 license. This pack can be bought separately.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Monday, January 24, 2011 8:59 AM
    Moderator
  • Hi Steff,

    Does that mean, we cannot use BizTalk 2006 with VS 2010. Which version of VS will give support to our requirement. We do not have licenses for 2009/2010 biztalk or adpater pack 2.0.

    Regards,

    Monday, January 24, 2011 9:15 AM
  • Steff, Sorry, I have confused the versions of Biztalk and VS. Thanks and Regards,
    Monday, January 24, 2011 9:31 AM
  • Hi,

    If you are working with BizTalk Server 2006 than BizTalk Adapter Pack 2.0 will be of no use as this supports only BizTalk 2006 R2 and above. Older adapters (i.e. Adapters for Enterprise Applications) support DB Oracle version you want select rows from. This document can be useful for you. There is in this case no need for Adapter Pack, unless you requirements for interacting with OracleDB that is not supported with Adapters for Enterprise Applications but with Adapter Pack 2.0. If so than you will have to upgrade your platform to BizTalk 2006 R2 or above.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Monday, January 24, 2011 12:01 PM
    Moderator