none
Proxy settings for dynamic ftp send port RRS feed

  • Question

  • Does anyone have an idea how to configure the proxy settings when using a dynamic send port to connect to an ftp server?

    When using the FTP send port there is the property 'Server' to specify the proxy settings, but how would this be done with a dynamic send port?
    I can't find anything about this. And there doesn't seem to be a property FTP.Server according to intellisence in my orchestration.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Monday, September 10, 2012 9:32 AM

Answers

  • Didn't try connecting using explorer, but did connect succesfully using the ftp client filezilla.

    We did found what was the cause in the mean time.
    Turned out  that our clients firewall wasn't configured correctly to let the connection pass. :)

    Thanks all for helping in this matter to find a solution.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    • Marked as answer by mitchke Tuesday, September 25, 2012 12:51 PM
    Tuesday, September 25, 2012 12:50 PM

All replies

  • I think in 2010 and before the dynamic ports run on the default host, so you can go configure the adapter send handler for FTP on the default host with your proxy settings.

    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, September 10, 2012 10:29 AM
  • Of course it will use the the settings in the adapter send handler.

    But cconfiguring your proxy for an ftp adapter is done like in this blog http://blogs.microsoft.co.il/blogs/shaharron/archive/2008/01/27/using-biztalk-to-send-a-file-to-an-ftp-server-via-a-proxy.aspx.
    And these settings aren't available in your general configurations of the ftp adapter.
    So this cannot be done as you suggest.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Monday, September 10, 2012 10:48 AM
  • I guess I am missing something, when I have had to use a proxy with FTP I have set these setting in either the send port configuration or in the send adapter hander, are you saying that does not work or that you cannot set it inside an orchestration using a dynamic port?


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, September 10, 2012 11:51 AM
  • Actually both.... I can't set them in the send adapter handler (how would you do that by the way?).
    It doesn't matter which one is used, I either need to configure the proxy on the send handler or in the orchestration.

    How would you set this in the send adapter handler? There doesn't seem to be any properties to do so.

    Below screenshot are the possibilities for the send adapter handler... so now proxy settings properties are available as you can see.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Monday, September 10, 2012 12:20 PM
  • Open the Firewall section, that is were I set the proxy information would be set, in almost all cases firewall and proxy are the same.

    Or at least it worked that way the last time I had to use it.


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, September 10, 2012 12:23 PM
  • was afraid of that... tried it, but doesn't seem to work though :s

    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Monday, September 10, 2012 12:25 PM
  • Can you post a screen shot of the settings?

    What mode were you using, I find that most firewalls/proxies don't support active, you need to specify passive mode.

    you may also need to specify host:<proxy port>

    What error were you getting?


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, September 10, 2012 12:34 PM
  • The received error is: Unable to connect to FTP server "87.xxx.xxx.xx" as user "FTPUSER". Inner Exception details: "No FTP server found on the specified address. ".

    This is the same error as before all changes (so without any proxy settings).
    And I'm certain that the ftp data is correct, as I'm able to connect using an ftp client as fileZilla to connect to the ftp location.

    Here's the screenshot of the ftp send handler settings:


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com


    • Edited by mitchke Monday, September 10, 2012 1:12 PM
    Monday, September 10, 2012 1:09 PM
  • I just want to make sure you know how the password dialog work in this screen, you have do enter your password and then hit enter, otherwise it does not save the password, ie. you cannot just click on the field below, you must hit enter when the password dialog is showing.

    I have has several client that have been caught with this mistake.

    Have you also tried, socks 4 & socks 5 for the type?


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, September 10, 2012 1:14 PM
  • Yeah, knew about the password dialog already.

    Also tried the other type possibilities this time.
    But still without any luck.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Monday, September 10, 2012 1:33 PM
  • It seems like most or all of the FTP properties are exposed in the Global Property Schemas assembly.  The FTP properties are under the "FTP" namespace (see FTP property schema below).

    One thing you might try is to get it working (simple messaging) using a static FTP send port.  Once it is working, turn on send port tracking of message properties (before and after port processing).  Inspect the tracked message for the FTP related properties set during static transmission and try setting these within your orchestration.

    <?xml version="1.0" encoding="utf-16"?>
    <xs:schema xmlns="http://schemas.microsoft.com/BizTalk/2003/ftp-properties" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" targetNamespace="http://schemas.microsoft.com/BizTalk/2003/ftp-properties" xmlns:xs="http://www.w3.org/2001/XMLSchema">
    	<xs:annotation>
    		<xs:appinfo>
    			<b:schemaInfo schema_type="property" xmlns:b="http://schemas.microsoft.com/BizTalk/2003"/>
    		</xs:appinfo>
    	</xs:annotation>
    	<xs:element name="RepresentationType" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="198b2027-4cde-4677-88f1-7b66caf6473a"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="SSOAffiliateApplication" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="8045bcbe-3285-412c-8b5a-dc3be5978c9b"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="UserName" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="6E789556-2F81-4fa6-B8E2-5214F1662289"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="Password" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" isSensitive="true" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="FEFD9283-C98A-470d-8E0A-C00214EE4047"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="BeforePut" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="58C0F130-2D2D-4374-8418-714A31046A58"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="AfterPut" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="CFBD9956-B0C6-48af-9257-4E27C7771998"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="ReceivedFileName" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="441B372A-23A1-4465-8329-F56AC0BDBFD8"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="MaxConnections" type="xs:unsignedInt">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="0A580338-036A-411B-A28A-1BCC86E56458"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="CommandLogFileName" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="CCE01F9B-8869-4216-BD7A-8F476FA40327"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="AllocateStorage" type="xs:boolean">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="4945CA1F-A812-483B-B32F-C98513EBF51E"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="PassiveMode" type="xs:boolean">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="74B6373E-550F-4434-B2D1-DE912ACDB3A7"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="SpoolingFolder" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="1C703221-ADE1-4DF7-9D6E-1770903DC614"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="UseSsl" type="xs:boolean">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="D032AB42-E927-470C-B5E8-E59A5E32851D"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="UseDataProtection" type="xs:boolean">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="42E3D7F0-5FF5-4C6E-8E72-BD76D203C6DD"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="FtpsConnectionMode" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="EDA0F134-3F42-4DD7-8428-75BA65E7C4CA"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    	<xs:element name="ClientCertificateHash" type="xs:string">
    		<xs:annotation>
    			<xs:appinfo>
    				<b:fieldInfo propSchFieldBase="MessageContextPropertyBase" xmlns:b="http://schemas.microsoft.com/BizTalk/2003" propertyGuid="423E6603-652E-4A61-B49F-B632031E3180"/>
    			</xs:appinfo>
    		</xs:annotation>
    	</xs:element>
    </xs:schema>
    


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.


    Monday, September 10, 2012 2:07 PM
  • Problem is that even with a static port we aren't able to connect to the FTP location.

    I do like to note that when changing the type of the firewall in the FTP settings on the port to SOCKS4 or SOCKS5, we get a different error message.
    The error in this case states that the firewall returns a wrong message.

    So I'm not sure whether it does or does not make a correct handshake with the proxy settings when the type is set to none.
    As with the type set to none the earlier stated error is returned, namely ' Unable to connect to FTP server "87.xxx.xxx.xx" as user "FTPUSER". Inner Exception details: "No FTP server found on the specified address. ". '


    any suggestions what to look for are welcome, I'm running out of ideas for this one :).


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    Friday, September 14, 2012 7:04 AM
  • Did you try connecting to the FTP location using explorer?  Use the following to impersonate the host instance:

    runas /noprofile /user:<domain | computer>\<account> explorer


    David Downing... If this answers your question, please Mark as the Answer. If this post is helpful, please vote as helpful.

    Friday, September 14, 2012 1:28 PM
  • Didn't try connecting using explorer, but did connect succesfully using the ftp client filezilla.

    We did found what was the cause in the mean time.
    Turned out  that our clients firewall wasn't configured correctly to let the connection pass. :)

    Thanks all for helping in this matter to find a solution.


    Kind regards,
    Mitch Vanhelden
    Blog: http://mitchvanhelden.blogspot.com

    • Marked as answer by mitchke Tuesday, September 25, 2012 12:51 PM
    Tuesday, September 25, 2012 12:50 PM
  • The solution in the blog link worked but with one change-

    instead of using EndTargetServerIP@UserName in username property, I had to use UserName@EndTargetServerIP

    Thanks for posting this helpful blog


    Regards, Ratnakar.


    Wednesday, February 12, 2014 11:58 AM