locked
Lightswitch Screen won't display data RRS feed

  • Question

  • Greetings,

    I have been working on a database, and recently ran into a small issue. I published an update to my (local) lightswitch project, and one of my tables stopped displaying data. The data wasn't lost, it was still there, just didn't want to show itself. The page count on it was correct, but wouldn't show in rows on the screen. 

    I had 2 screens that accessed the same data; one was an editable grid, the other as list and details. Both stopped showing the data when I did the update. I managed to get the list and details working again after I remade the table, but I couldn't get the editable grid to work. I tried rebuilding it, doing different queries, deleting it and making a new screen, etc. Nothing I am doing works.

    I have verified in SQL server that the data is there. Does anyone know how to get it to display the data again? I've tried searching, but nothing seems to answer my question.

    Thanks!

    Friday, July 26, 2013 6:40 PM

Answers

  • Hi,

    You probably have introduced a mandatory column/property, be it data or a relationship. Because of this, or similar, the data records will be filtered out. You may be able to update the records to fill in a default value or link such that they become valid and reappear.

    If you cannot figure it out, then get back with the before-change-after details and someone here will be able to help.

    Cheers

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    • Proposed as answer by babloo1436 Saturday, July 27, 2013 5:30 PM
    • Marked as answer by Angie Xu Monday, August 5, 2013 12:36 AM
    Friday, July 26, 2013 7:33 PM