locked
Problem with data service in IIS7 RRS feed

  • Question

  • I have a dataservice which is running perfectly fine when started with visual studio dev server. In IIS7, the svc file shows up but when I append table names I get this message:

    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

    For more information about HTTP errors, see Help.

     

     

    Wednesday, February 1, 2012 3:21 PM

Answers

  • This is resolved now. The problem was that IIS app pool dint had access to sql server. This is the code which resolved the issue:

    CREATE LOGIN [IIS APPPOOL\ASP.NET v4.0]
      FROM WINDOWS WITH DEFAULT_DATABASE=[master],
      DEFAULT_LANGUAGE=[us_english]
    GO
    CREATE USER [Username]
      FOR LOGIN [IIS APPPOOL\ASP.NET v4.0]
    GO
    EXEC sp_addrolemember 'db_datareader', 'Username'

     

    Thursday, February 2, 2012 1:21 PM

All replies

  • Hi,

    please enable verbose error reporting, that should tell you something about what went wrong:

    http://blogs.msdn.com/b/phaniraj/archive/2008/06/18/debugging-ado-net-data-services.aspx

    Thanks,


    Vitek Karas [MSFT]
    • Proposed as answer by SOW Bano Friday, February 3, 2012 1:42 PM
    Wednesday, February 1, 2012 7:20 PM
    Moderator
  • This is resolved now. The problem was that IIS app pool dint had access to sql server. This is the code which resolved the issue:

    CREATE LOGIN [IIS APPPOOL\ASP.NET v4.0]
      FROM WINDOWS WITH DEFAULT_DATABASE=[master],
      DEFAULT_LANGUAGE=[us_english]
    GO
    CREATE USER [Username]
      FOR LOGIN [IIS APPPOOL\ASP.NET v4.0]
    GO
    EXEC sp_addrolemember 'db_datareader', 'Username'

     

    Thursday, February 2, 2012 1:21 PM
  • Cool ! Thank to share the solution .

    Best regards


    So B
    Friday, February 3, 2012 1:41 PM