Unable to login to Reporting Services


  • I'm unable to login to Reporting Services on local host. I have installed SQL Server 2012 on Windows 7, but it doesn't accept the user I enter. I've checked the user and the url, and I'm sure it is fine. I've tried different types of authentication with the same result. The login prompt appears always again.

    Does anyone have any idea on what might be causing me not to be able to access locally?


    Wednesday, July 10, 2013 11:18 AM

All replies

  • Hi Lewispe,

    Firstly, please ensure that the Reporting Services was configured successfully. You can refer to the link below to check it:Verify a Reporting Services Installation

    Secondly, please ensure that the user is a member of the local Administrators group because on a new report server installation, only users who are members of the local Administrators group have permissions to report server content and operations.

    Besides, you need to run the browser in the elevated privilege mode.Right click on the browser and then select "Run as Administrator"

    Hope this helps.


    Charlie Liao
    TechNet Community Support

    Thursday, July 11, 2013 6:46 AM
  • What error are  you getting?

    Best Regards,Uri Dimant SQL Server MVP,

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Blog: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance

    Thursday, July 11, 2013 7:07 AM
  • try below ...

    Open the internet explore with Run as "Administrator" and try opening reporting services from that IE...

    Thursday, July 11, 2013 8:31 AM
  • Running IE as administrator seems to work fine. It appears the name of the local host and the SSRS version:

    Microsoft SQL Server Reporting Services Versión 11.0.3128.0

    But when I execute a report from Visual Studio the problem persists...


    • Marked as answer by Lewispe Thursday, July 11, 2013 3:49 PM
    • Unmarked as answer by Lewispe Thursday, July 11, 2013 3:49 PM
    Thursday, July 11, 2013 3:49 PM
  • Hello Uri Dimant

    There is no errors. Simply the login prompt appears again and again when trying to publish a report from Visual Studio.

    Thanks for your interest

    Thursday, July 11, 2013 3:52 PM
  • Hi Charlie.

    How can I add the reporting service user to the local administrators group? I have Windows 7 Home Premium


    Thursday, July 11, 2013 3:59 PM
  • Hi Lewispe,

    Please refer to the link below to see how to add a user to a group.
    Add a user account to a group


    Charlie Liao
    TechNet Community Support

    Friday, July 12, 2013 2:48 AM
  • Hi Charlie,

    The local users and groups snap-in has been disabled in Windows 7 Home Premium. I've tried to do that by using the net localgroup command, but as I'm using a virtual account (NT Service\ReportServer$SQLEXPRESS), it's not possible. Anyway, I've added the Network Service user to the Administrators group, and I've changed the service account as well from the Reporting Service Configuration tool. Then I've tried to run a report from Visual Studio (run as administrator) with the same result as usual: the prompt login.

    The installation looks fine, I can log in with IE as administrator and it doesn't seem to be an user permissions issue.

    Really I've tried everything and always with the same result. Any suggestion?


    Friday, July 12, 2013 4:58 PM