none
error: 40 - Could not open a connection to SQL Server) RRS feed

  • Question

  • An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)


    kindly provide me the right way to solve this problem .I have also try this but didnt find success fo an problem

    Start->Programs->Sql Server 2005->Configuration Tools->SQL Server Surface Area Configuration. Click "Surface Area Configuration for Services and Connections". Choose "Database Engine->Remote Connections", select "Local and Remote Connections".

    Wednesday, September 26, 2007 6:49 AM

Answers

  • SQL Server error 40 is just a generic error that comes with many ending codes which explains your actual error, I remember when we got error 40, 53 which means that SQL Server is down. So go to the link below and find your ending code for the solution. And you also need to go into the configuration manager and enable TCP/IP, Named Pipes and the Browser service because I do it in both and only get this error when reporting services drop my connection string which is a known annoyance. Hope this helps.

     

    http://blogs.msdn.com/sql_protocols/archive/2005/09/28/474698.aspx

    Wednesday, September 26, 2007 2:42 PM

All replies

  •  

    Check out "How to configure SQL Server 2005 to allow remote connections" http://support.microsoft.com/kb/914277

     

    I guess you're missing enabling a protocol in step 3 in the KB article

     

    regards,

    faruk celik

    Wednesday, September 26, 2007 9:05 AM
  • SQL Server error 40 is just a generic error that comes with many ending codes which explains your actual error, I remember when we got error 40, 53 which means that SQL Server is down. So go to the link below and find your ending code for the solution. And you also need to go into the configuration manager and enable TCP/IP, Named Pipes and the Browser service because I do it in both and only get this error when reporting services drop my connection string which is a known annoyance. Hope this helps.

     

    http://blogs.msdn.com/sql_protocols/archive/2005/09/28/474698.aspx

    Wednesday, September 26, 2007 2:42 PM