none
Change Working Time - For Calendar RRS feed

  • Question

  • When trying to build a 24 hour schedule with (2) 12 hour shifts, I was able to go into the "Project" tab and "Change Working Time" button, change the "For calendar" to 24 hours, go into the "Work Weeks" and set Sunday through Saturday to 2 shifts, one from 12:00AM to 11:59AM and one from 12:00PM to 11:59PM.  I hit okay to set all of this.  I also went into "Project Options" and changed the default start time to 12:00AM and the default end time to 11:59PM.  I changed the hours per day to 12 hours per day, 84 hours per week, and 31 days per month.

    Now when I click on the same task and hit the "Change Working Time", the "For calendar" displays "Standard (Project Calendar)" which defaults to the 8AM-12PM and 1PM-5PM.  No matter how many times I change it, it always defaults to this.  Therefore, if I put a duration longer than 8 hours (say 9, which should still be finished in 1 shift) the scheduling pushes it to finish the next day.  I can't figure this out. 

    To add to this, the timeline at the top shows an 8AM to 4PM day.  I am not sure if that is related, but that is a third timeline that is different still!

    Is there something wrong with my master settings somewhere?  Does it have something to do with this being a server license?  Again, I am creating this project from scratch.  Thanks for the help!

    Wednesday, March 15, 2017 9:03 PM

All replies

  • cpr2013,

    First of all, there is already a built-in calendar for 24 hours. That should be your Project Calendar (Project > Properties group > Project Information). Then you should create two new custom calendars, one for each shift. The first shift calendar should go from 12:00AM to 12:00PM (i.e. midnight to noon). The second shift calendar should go from 12:00PM to 12:00AM (i.e. noon to midnight).

    You might also need to change your Project Start Date (Project > Properties group > Project Information), so it reflects starting at 12:00AM, otherwise the first task(s) will default to an 8:00AM start time.

    Unless certain tasks need a different calendar, all tasks will default to the Project calendar. Resources working 1st shift should have a Base Calendar (Resource Sheet) of the custom first shift created above and all resources working 2nd shift should have a Base Calnedar of the custom second shift created above.

    Your settings for 12 hours per day is correct as that will insure the Duration field shows full 12 hour days. Setting for hours per week isn't really important unless you enter durations in weeks. A setting of 31 days per month won't really do any good since not all months have 31 days.

    Anyway, try the above and see if that works for you.

    John

    Wednesday, March 15, 2017 9:50 PM