locked
Wrong Location on maps using MapPoint Webservices RRS feed

  • Question

  • Thanks in advance for your help.  I am using the older MapPoint services. I see this problem on both the staging and production service. Any help will be greatly appreciated.

    I have a address 2340 Irving St Suite 108 San Francisco Ca 94122. With or without the suite 108, the webservice is getting back a wrong location on the map and hence wrong distances from any address I type. For eg,
    Add A: 1201 green st San Francisco CA
    Add B: 2340 Irving St Suite 108 San Francisco CA 94122 (problem one)
    Correct distance between them is around 5.87 or so miles but it shows 0.65 miles on the map.
    Rest all addresses are also a little off by around 0.5 miles every now and then but that I assumed because MapPoint WS is older and Bing maps are more accurate.

    Please help me with this, I need to find a resolution to this as soon as possible.

    Thanks again for your help.

    Thursday, October 21, 2010 8:02 PM

Answers

  • How are you passing your address to MapPoint? If you're providing a formatted address line like you did above, it's quite important to include commas. As you mentioned it's an older service, so it depends on commas to help parse addresses. Try again with commas separating the elements and see if you get a better result. I tested your address as below and got a good result that matched Bing Maps.

    2340 Irving St, San Francisco, CA, 94122

    Friday, October 22, 2010 1:28 PM