none
Failed Installation of .NET Framework 3.5 SP1 on Vista 32 bit RRS feed

  • Question

  • I'm trying to download .NET Framework 3.5 SP1 on my Windows Vista 32 bit. I have previously tried to use the Cleanup Tool to get rid of my .NETs (all of them) and redownloaded them. Now I've been able to download up to .NET Framework 3.5, but whenever I try to install the .NET Framework 3.5 SP1, it told me to use the Windows Turn on or Off function. So I went there and tried to check the box for the .NET Framework 3.5, but when I pressed OK, it told me not all of them could be turned on. I tried to install the framework anyways to see if it would still work and it gave me an error, so I looked at the error log and this is what it said:

    [03/12/11,14:50:38] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 1
    [03/12/11,15:13:01] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 1
    [03/12/11,15:13:03] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

    I've tried reading up on this but I'm not really a computer person, so I don't completely understand this language. But I do know that when I tried to download .NET Framework 2.0 SP1 previously it said my computer already had that in the OS, so I skipped it and went on to downloading .NET Framework 3.0, etc.

    I verified all of my existing components, and all except .NET Framework 3.5 were verified. I'm not going to post the log with the error since it's incredibly long. But if you tell me where to send the log to I can do that if need be.

    If you have any ideas on how to fix my issue, please let me know. Thanks
    Saturday, March 12, 2011 9:46 PM

Answers

All replies

  • You can post your log to a publicly-accessible site like SkyDrive:

    http://windows.microsoft.com/en-us/windows7/introducing-skydrive-password-protected-online-file-storage

    then, post the link here.

    You might try this:

    First, use this tool to remove any remnants of .NET Framework 3.5 *only*:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    then, try this cumulative update that will detect frameworks already installed and install only what's needed through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

     

    Sunday, March 13, 2011 3:52 PM
  • Hi Lorali,

    Thanks for your post.

    Since the .NET Framework 3.0 is installed as system component, to install the .NET Framework 3.0, you should go to Control Panel -> Turn Windows Features On or Off.

    • If the checkbox of the Microsoft .NET Framework 3.0 is selected, try to unselect it, click Ok; then open it again and select the checkbox, click OK.
    • If the checkbox is not selected, select the checkbox, click OK.
    • If there are any error occurs, would you please help to provide the error message?

    Like pvdg42 said, then you could download and install the .NET Framework 3.5 SP1.

    I hope this helps.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 14, 2011 6:30 AM
    Moderator
  • I have been having issues with frameworks since november and it has just totally stopped working all together..even when i would try to fix the errors or update my frameworks,it would only show piles of error messages. so i went through one by one and uninstalled each and every one. now i'm facing the hard fact that i can not even reinstall them. I do not know what to do to fix this hindering problem of mine.Can any one help or point me in the right direction so i may solve it myself atleast??? pls help me :(
    Thursday, March 17, 2011 5:22 PM