Web application no longer works RRS feed

  • Question

  • User-1250180659 posted

    I had built a small web application using .net framework 4.5.2, C#, Entity framework and Ninject. When I ran it in Visual Studio, IIS Express would launch in my system tray and the browser would present me with my working web application at http://localhost:xxxx.

    Now, I have been experimenting with Visual Studio's 'Publish' feature on my project and since then my web application no longer works correctly. I get the following error:

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    It seems like IIS Express no longer understands my web application and it mistakes it for a static web application.

    What I had done for this error to show up:

    • publish my web app as File System and point it to an existing virtual directory under my real IIS8 instance (not IIS Express that comes with Visual Studio)
    • Change folder permissions on my published application (IIS_IUSRS and IUSR read, modify, write)

    For some strange reason now, Visual Studio brings the Azure App Service Activity tab into focus every time I start my web application.

    What I have tried to fix this:

    • reinstall Visual Studio
    • reinstall IIS Express
    • removing app pools from the default IIS8 application that comes with Windows 8 and setting things back to normal
    • remove the web apps I hosted that were linked to this one

    I don't understand what went wrong.

    What can I do so that my web application runs back as normal?

    // EDIT: Very odd.. I chose my Web\index.html 'Set As Start Page' and I ran my application again. Now it works. If someone could explain what's going on here, I would be thankful.

    Thursday, May 11, 2017 9:51 PM

All replies