locked
The metro style app C++ sample code can't deploy

    General discussion

  • I'm studying about metro style app on windows8. and I follow this page to make sample.

    http://msdn.microsoft.com/en-us/library/windows/apps/hh465045

    But when i build new project, it can't deploy this. and the msg said

    Error : DEP0800 : The required framework "C:\Program Files\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.VCLibs\11.0\.\AppX\Debug\ARM\Microsoft.VCLibs.ARM.Debug.11.appx" failed to install.
    1>Windows cannot install package Microsoft.VCLibs.110.Debug because the package requires architecture ARM, but this computer has architecture x86.

    i try changing solution platform, but it didn't work.

    at windows 8 Release Preview and  Visual Studio 2012 Express RC for Windows 8.

    Tuesday, June 26, 2012 10:09 AM

All replies

  • Hello,

     

    Is your Windows 8 is ARM version? If your system is X86 or X64, I would suggest you to configure the platform as Win32, and try again.

     

    Best regards,

    Jesse



    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, June 27, 2012 7:01 AM
  • thanks for reply, Jiang.

    My Windows8 is x86 version.

    And I tried changing solution flatform already...

    ARM, Win32 and x64 all didn't working.

    Additionally The file is located right path.

    please help...

    Wednesday, June 27, 2012 7:40 AM
  • I'm facing same problem...

    Please let me know if there is a way to solve this...

    Br,

    Thursday, July 05, 2012 12:08 PM
  • Can you send me the project?

    email is first name dot last name at microsoft dot com

    Thursday, July 05, 2012 5:45 PM
    Moderator
  • May be you are working on windows 8 which version is newer than build 8400 with VS2012 RC.

    Friday, July 06, 2012 7:24 AM
  • This public forum is only for publicly available versions of Windows 8 (Release Preview, v8400) and Visual Studio 2012 (Release Candidate, v50522.1). You shouldn't be discussing non-public releases here. Please contact your program representative for support on this.

    If anyone is reproducing this on Win8 RP + VS RC, please send me the project that reproduces the issue.

    Monday, July 09, 2012 7:45 PM
    Moderator
  • try release version, you can still debug it.
    Friday, July 13, 2012 3:06 AM
  • Facing the exact same problem here, building Release changes nothing. Problem persists across any projects I import or create from scratch.

    If anyone wants to swap notes please shoot me an email at win8cppdev at gmail

    Friday, July 13, 2012 11:55 PM
  • If anyone is having this issue using Win8 RP and VS2012RC Please send Steve or I a project or APPX package to investigate. My email is DavidLam at Microsoft dot COM.

    Update: If you are part of a program that access to builds of Win8 other than the builds posted Here, then you will need to obtain the proper version of Visual Studio that aligns with that build of Windows from that channel. The RC version of VS 2012 is for use on the Win8 Release Preview only.


    David Lamb


    Saturday, July 14, 2012 12:41 AM
    Moderator