none
Issue related to esb Managemet portal RRS feed

  • Question

  • Hi,

    I have installed Esb management portal but while  Browsing Esb.portal I got Unhandled exception screen,

    Also errors in event viewer continuously.

    Access denied. The client user must be a member of one of the following accounts to perform this function.
     SSO Administrators: Domain\SSO Administrators
     SSO Affiliate Administrators: Domain\SSO Affiliate Administrators
     Application Administrators: Domain\BizTalk Server Administrators
     Application Users: -
     Additional Data: Domain\ServerName$ ESB App.cachingConfiguration Config Data

    Also

    Access denied. See the event log (on computer 'ServerName') for more details.

    Also

    SSO AUDIT
     Function: GetConfigInfo (SSOProperties)
     Tracking ID: 14cfbb2d-0674-43cb-83e6-9dc2ea2ea773
     Client Computer: ServerName.Domain (w3wp.exe:6328)
     Client User: Domain\ServerName$
     Application Name: ESB App.cachingConfiguration
     Error Code: 0x80070005, Access is denied.

    Also

    SSO AUDIT
     Function: GetConfigInfo (SSOProperties)
     Tracking ID: 52563fe1-e443-45c6-920e-bc6da013b522
     Client Computer:ServerName.Domain (w3wp.exe:6328)
     Client User: Domain\ServerName$
     Application Name: ESB App.instrumentationConfiguration
     Error Code: 0x80070005, Access is denied.

    and etc

    Please help me.

    Tuesday, May 10, 2016 11:32 AM

Answers

All replies

  • Hi Dinesh

    I hope you have run the ESB Configuration Tool successfully-

    https://msdn.microsoft.com/en-in/library/jj684558.aspx

    If yes, refer this-

    First open both the web.config files mentioned below and check the connectionStrings - are they pointing to the correct ESB database/database server?

    Also, verify that the correct domain groups you have used during ESB Configuration Wizard are mentioned in the config files.

    https://social.msdn.microsoft.com/Forums/en-US/d53ecd9e-bbc4-4d60-ac58-aa6ece6914ba/esbportal-4012-access-denied-error?forum=biztalkesb

    You have to edit the ESB.Portal web.config & ESB.Exceptions.Services web.config and:

    a) Change the connection string to the ESB databases
    b) Change the authentication roles to the actual AD groups you are using for BizTalk


    Also, check the troubleshooting steps here-

    http://biztalkintegrationblog.jnicolas.name/biztalk-esb-management-console-admin-access-denied/


    Thanks Arindam





    Tuesday, May 10, 2016 12:52 PM
    Moderator
  • Hi i have following code in Esb.portal config file:

    for connections:

    <connectionStrings>
    <!--<add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=biz64-801-01;Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient"/>-->
    <!--<add name="EsbExceptionDb" connectionString="Network Library=dbmssocn;Data Source=biztalk2k801;Initial Catalog=EsbExceptionDb;Integrated Security=True;" providerName="System.Data.SqlClient" />-->
    <add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=(local);Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient" />
    <!--<add name="EsbExceptionDb" connectionString="Data Source=biztalk2k802;Initial Catalog=EsbExceptionDb;Integrated Security=True;Application Name=Microsoft.Practices.ESB.Portal"/>-->
    </connectionStrings>

    For Groups:

    <authentication mode="Windows" />
    <authorization>
    <allow roles="BizTalk Application Users" />
    <allow roles="BizTalk Server Administrators" />
    <allow roles="Administrators" />
    <deny users="*" />
    </authorization>

    And i find following code in ESB.Exceptions.Services  config file:

    <connectionStrings>
      <add name="EsbExceptionDbConnectionString" connectionString="Integrated Security=SSPI;Data Source=.;Initial Catalog=EsbExceptionDb" providerName="System.Data.SqlClient" />
     </connectionStrings>

     it shows that pointing to local , so what i need to change in both config files.

    Wednesday, May 11, 2016 5:10 AM
  • Hi 

    The biggest concerns I have is your datasource is set as local in both cases-

    <add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=(local);Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient" />

    <add name="EsbExceptionDbConnectionString" connectionString="Integrated Security=SSPI;Data Source=.;Initial Catalog=EsbExceptionDb" providerName="System.Data.SqlClient" />

    Is your database server hosted locally?


    Thanks Arindam

    Wednesday, May 11, 2016 6:21 AM
    Moderator
  • No,I have separate sql server.

    but i have installed sql in Biztalk server also.

    Wednesday, May 11, 2016 6:51 AM
  • I am getting following error while browsing esb.portal

    Also in event viewer:

    Login failed for user 'Domain\user'. Reason: Failed to open the explicitly specified database 'EsbExceptionDb'. [CLIENT: <local machine>]

    Wednesday, May 11, 2016 11:24 AM
  • Any reason to do that? It's not at all recommended.

    Thanks Arindam

    Wednesday, May 11, 2016 12:26 PM
    Moderator
  • Okay, so when you say that the EsbExceptionDb is created, does it exist on the local SQL Server or on a different SQL Server.

    You have to replace the local  or . in the connection string with the actual SQL Server name, if it's a remote SQL Server where you have the ESB databases.

    Also, I suspect the installation may not have been done in a supported manner. Was this a new/fresh installation of BizTalk and ESB Toolkit?


    Thanks Arindam


    Wednesday, May 11, 2016 12:29 PM
    Moderator
  • Hi,

    EsbExceptionDb is created in different  sql server.

    yes  it is a new/fresh installation of BizTalk and ESB Toolkit.

    also In local sql i found the following databases:

    Reportserver

    reportservertempdb

    ssodb

    uddi3.

    is it not proper way of installation. any thing wrong of installing sql in biztalk server.


    Thursday, May 12, 2016 5:03 AM
  • It is certainly not recommended - SQL Server is resource hungry and will compete with resources with the BizTalk services. Also, why would you do that? 

    Go to Admin Console -> rt-click BizTalk Group ->  Properties. Now check the Server. What is the database server? If it is the remote server, remove SQL Server locally - atleast stop SQL Server.

    Then, replace the correct server names in the connectionstring as I suggested earlier.


    Thanks Arindam

    Thursday, May 12, 2016 5:23 AM
    Moderator
  • If i stop sql server in biztalk server how uddi is run.

    Also  i have read some articles sql is needed in biztalk.

    once in my 2010 sql was un installed so i got problems previously.

    also i want to know how ssodb and reportserver s are created in local.

    also ssodb is created in remote sql server.  how to know which ssodb is iam using currently. also  while working with esb related apps applications working properly but lot of  in eventviewer error  sso audit errors, application does not exist error i am getting




    • Edited by DineshNad Thursday, May 12, 2016 5:42 AM
    Thursday, May 12, 2016 5:34 AM
  • Hi

    Did you check what I mentioned in previous post?

    Go to "Program Files\Common Files\Enterprise Single Sign-On" from command prompt, and type ssoconfig -showdb

    This will show the SSO DbServer.

    SQL Client is needed on BizTalk, not the server. Try stopping the local SQL server instance, and check if BizTalk is running fine.

    "also i want to know how ssodb and reportserver s are created in local."

    I suspect a wrong configuration where local was provided as SQL Server Name - maybe the configuration wizard was run incorrectly once before this current configuration happened? Eitherway, it's an error at your side that has happened.

    Are you using UDDI? If not, there's no need to configure it, and no need for the UDDI database as well.


    Thanks Arindam






    Thursday, May 12, 2016 6:19 AM
    Moderator
  • sso db  server is showing as  remote sql server.

    and How ssodb and reportserver s are created in local , iam also not understanding.May be  this is the issue (first time i am running the biztalk server configuration   with out any groups created ssodb may created , But i want to know at what stage of configuration  reportserver  database  will be  created ).


    Thursday, May 12, 2016 6:42 AM
  • At no stage at all - I guess when you ran SQL Server installer, you selected SSRS option as well - that may have created it locally.

    Thanks Arindam

    Thursday, May 12, 2016 6:54 AM
    Moderator
  • Then  what is the solution. But  reportserver  is not available in actual Sql server (Remote)
    Thursday, May 12, 2016 12:18 PM
  • Yes, when you installed SQL Server locally, you also installed SSRS- that's why you are seeing that database.

    What I would do - stop SQL Server service on local BizTalk machine and check if BizTalk is running fine. If yes, keep it stopped, and eventually plan to uninstall it from local/BizTalk machine.

    Regarding ESB connectionStrings, replace local and . (in both config files) with your actual SQL Server name and test if the portal launches.


    Thanks Arindam

    Thursday, May 12, 2016 12:46 PM
    Moderator
  • In esbportal config file it is pointing to ESBAdminas Below:

    <add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=(local);Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient" />

    But this data base is not created in my Sqlserver.

    Thursday, May 12, 2016 1:29 PM
  • Correct - does it exist in your actual/remote SQL Server?

    If not, you have to reconfigure ESB from scratch.


    Thanks Arindam

    Thursday, May 12, 2016 2:17 PM
    Moderator
  • Hi,

    EsbAdmin is  created based on script written in Management_Install.ps1

    Please refer the below Link and  say Your opinion.

    https://social.msdn.microsoft.com/Forums/en-US/2979f904-0c77-4e80-8af7-7ba8b09cbab8/biztalk-esb-portal-set-up-failing-while-creating-the-esbadmin-database?forum=biztalkesb

    Friday, May 13, 2016 7:23 AM
  • Hi

    But you said EsbAdmin is already created on SQL Server for you - meaning you have already gone through the steps above. Isn't that the case?


    Thanks Arindam

    Friday, May 13, 2016 8:37 AM
    Moderator
  • No,

    i have run the power shell script every thing fine but EsbAdmin db is not created.

    Am i need to change  powershell script as mentioned in the above thread.

    Friday, May 13, 2016 9:19 AM
  • Which version of BizTalk is this? Did you check if ESBAdmin got created on your local DB?

    If the script failed, you should have got an error. Did you get any errors?

    If you're on BizTalk 2013, you don't need to modify any scripts. Follow the steps shared here-

    https://social.msdn.microsoft.com/Forums/en-US/2979f904-0c77-4e80-8af7-7ba8b09cbab8/biztalk-esb-portal-set-up-failing-while-creating-the-esbadmin-database?forum=biztalkesb


    Thanks Arindam

    Friday, May 13, 2016 9:28 AM
    Moderator
  • I am using Biztalk server 2013 R2.

    No it is not created in my local DB.

    and error i am getting while running  power shell command is as follows:

    Monday, May 16, 2016 6:08 AM
  • Ok, can you modify Management_Install.ps1 as per the link you shared earlier to contain your database ServerName, and give it a try.

    Thanks Arindam

    Monday, May 16, 2016 6:24 AM
    Moderator
  • hi

    i have find the following code in Power shellscript:

    RunDatabaseScript $relativePath"\SQL\ESB.Administration Database.sql" $args[1]

    so as per above link above :

    $dbservername = Read-Host "Please Enter the SQL Servername(servername\instancename) for ESB Portal Database"
    RunDatabaseScript $dbservername $relativePath"\SQL\ESB.Administration Database.sql"

    so  i changed as follows:$dbservername = Read-Host "ABCSERVER,portNumber\?"
    RunDatabaseScript $dbservername $relativePath"\SQL\ESB.Administration Database.sql"  $args[1]

    What  instance name i need to specify(ESBAdmin) or what?

    Monday, May 16, 2016 7:34 AM
  • Hi

    If you are using default instance of SQL Server, you don't need instance name, just provide servername-

    So, it will be -

    $dbservername = Read-Host "ABCSERVER,portNumber"


    Thanks Arindam

    Monday, May 16, 2016 7:37 AM
    Moderator
  • Thanks Arindam.

    After changing the DataSource in the web.Config files of ESB.Portal and ESB.Exceptions.Services. It got fixed. 

    ESB.Portal Config File

    <add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=SQLServerName;Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient"/>

    ESB.Exceptions.Service Config File

    <add name="EsbExceptionDbConnectionString" connectionString="Integrated Security=SSPI;Data Source=SQLServerName;Initial Catalog=EsbExceptionDb" providerName="System.Data.SqlClient" />

    Monday, February 11, 2019 5:56 AM