locked
Breakpoint will not be hit..Cant debug after copying project to another computer. RRS feed

  • Question

  • Hi,

    I am trying to run my project in Visual Studio 2010 after copying to my personal computer from my development pc. When I run it with breakpoints set, I see my breakpoints in yellow clor with exclamation mark in them. When I hover on it, it says breakpoint will not be hit, symbols have not been loaded.

    Can anyone please help?

    I need to sort this urgently.

    Thanks

    Thursday, July 29, 2010 10:56 AM

Answers

  • Hello,

    Thanks for your reply!

    The Modules window is available when debugging, which means, it is visible after you press F5 to start debugging. Please check it.

    In your case, I suspect you set a breakpoint in WCF service souce code and want to debug into the line where you set the breakpoint. There are a little bit more configuration for WCF service since we need WCF service to communicate across domain, this could be done by adding two xml configuration file. After this step, when debugging, you need to attach to the WCF service process when debugging to load the symbol files of WCF service. I uploaded a document for doing that here, hope it could help you!

    If you have any question, please don't hesitate and feedback here.
    Best regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    • Edited by liurong luo Friday, July 30, 2010 4:55 PM link URL
    • Proposed as answer by liurong luo Thursday, August 5, 2010 10:12 AM
    • Marked as answer by liurong luo Thursday, August 5, 2010 10:12 AM
    Friday, July 30, 2010 4:54 PM

All replies

  • Hello,

    Can I ask what kind of project it is? Can you please rebuild your project in your personal computer? The symbol files are generated after building your project. If you use other component. for example, a thirdpart assembly, you may need to ask for the symbol file from the provider.

    To check the symbol file status, you could go to Debug -> Windows -> Module. This window enables you to view the modules you need and their symbol files status. If the symbol file is not loaded, please right click the module name and select Load Symbols From..., or click Symbol Settings to let Vs know where to search the symbols.

    Best regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    Friday, July 30, 2010 3:37 AM
  • Hi Roahn,

    My project is a silverlight app that communicates with WCF service to connect to db. I did build and clean it before running and I cant see any option called Module in Debug->Windows. 

    Thanks for replying.

     

    Friday, July 30, 2010 4:01 PM
  • Hello,

    Thanks for your reply!

    The Modules window is available when debugging, which means, it is visible after you press F5 to start debugging. Please check it.

    In your case, I suspect you set a breakpoint in WCF service souce code and want to debug into the line where you set the breakpoint. There are a little bit more configuration for WCF service since we need WCF service to communicate across domain, this could be done by adding two xml configuration file. After this step, when debugging, you need to attach to the WCF service process when debugging to load the symbol files of WCF service. I uploaded a document for doing that here, hope it could help you!

    If you have any question, please don't hesitate and feedback here.
    Best regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    • Edited by liurong luo Friday, July 30, 2010 4:55 PM link URL
    • Proposed as answer by liurong luo Thursday, August 5, 2010 10:12 AM
    • Marked as answer by liurong luo Thursday, August 5, 2010 10:12 AM
    Friday, July 30, 2010 4:54 PM