locked
Unable to disable or delete Azure Replicated IAAS Vm from siter recovery RRS feed

  • Question

  • Hi Team,

    I recently created replication in azure from azure site recovery (Preview). I tested one of my VM's and tried replication. After testing I mistakenly deleted replicated IAAS virtual machine which was created and then I tried to disable  and remove the replicated Items from azure. But I got an error while disabling and removing the items from it. Then, I began to search the issue and found that I first need to disable/remove the IAAS replicated Items from site recovery and then I have to delete the IAAS replicated VM's individually.

    So, Is there any other way out to delete the replicated ITEMS from azure apart from this. I have also attached error which I got while disabling/removing the ITEMS for the reference.

    If any further more information is required please do let me know.

    Thank you in advance.

    Thank you,

    Bishal


    Regards, Bishal


    • Edited by Zenithcalls Thursday, August 10, 2017 12:27 PM Forgot to upload an image
    Thursday, August 10, 2017 12:11 PM

Answers

  • Which option (Disable replication and remove or Remove) have you selected while disabling the protection?

    If you didn’t try remove option, try to disable the protection by selecting remove option and let us know the status.

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Marked as answer by Zenithcalls Monday, August 14, 2017 8:50 AM
    Sunday, August 13, 2017 8:45 PM

All replies

  • I recommend you create a technical support ticket to find the root cause of the issue. The ticket enables you to work closely with the support engineers and get a quick resolution for your issue.

    raise a support ticket for Azure Site Recovery, reach out to Azure Support by using the URL at  http://aka.ms/getazuresupport.

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Thursday, August 10, 2017 7:07 PM
  • Hi Vikranth

    Thank you for the response. I already mentioned that the main cause was I mistakenly deleted the VM's which was created after enabling the replication. For example : my current vm location is westus with the name " testvm1". After enabling replication in the target location centralus  the replicated VM name was created i.e. "testvm1.asr". I tested everything and tried to remove the replication I mistakenly deleted the replicated vm first which was created. Then, I tried to disable the replicated item from recovery service vault but I got an error which I already attached in the previous post.

    The actual process needs to done was first to remove/disable replication items from recovery service vault and then manually delete the replicated vm's which I had done just opposite and couldn't remove the replicated items from azure recovery service vault.

    I just want to know is there any other alternative ways to remove or disable the replicated vm's from vault. "Also I searched the error and it says the vm machine couldn't be found".

    Thank you,

    Bishal


    Regards, Bishal

    Thursday, August 10, 2017 7:46 PM
  • Which option (Disable replication and remove or Remove) have you selected while disabling the protection?

    If you didn’t try remove option, try to disable the protection by selecting remove option and let us know the status.

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    • Marked as answer by Zenithcalls Monday, August 14, 2017 8:50 AM
    Sunday, August 13, 2017 8:45 PM
  • Hi,

    I tried both disable and remove option but got an error which I have already attached in my previous discussion.

    Scenario:

    1. I first deleted the replicated VM i.e. Group name: test.asr , VM Name: test1

    2. Then, I tried to remove and disable the replicated VM which I got an error.

    Again, I created new replicated VM and tried another option i.e.

    1. First I remove and disable the replicated VM from replicated Items in azure.

    2. Then, I removed the VM which I was succesfull.

    Now, The first one which I created I am not able to delete the VM as it is saying VM is not found. So, is there any solution which I can remove from replicated items.

    Thank you,

    Bishal


    Regards, Bishal

    Monday, August 14, 2017 8:48 AM
  • Hi Vikrant,

    Sorry for above message. I tried to remove replicated items by selecting "remove" and was able to delete the items now.

    Thank you so much for your effort and help.

    Thank you,

    Bishal


    Regards, Bishal

    Monday, August 14, 2017 8:52 AM
  • I'm glad to hear that your issue is resolved.

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Monday, August 14, 2017 11:51 AM