none
BizTalk AS2 Certificate configuration problem RRS feed

  • Question

  • Hi,

    I'm having a problem with signing a certificate to send port. I have imported 2 diferent certificates in mmc to "Local Computer\Other People" and "Local Computer\Trusted Root Certification Authorities". Then I went to BTAdmin and select some Send Port then Certificate then Browse. One of certificates was there and other was not.

    Then I went on this page http://msdn.microsoft.com/en-us/library/bb728096.aspx and found this:

    "Certificates used for AS2 transport must have the attributes required for their intended use. For signing and signature verification, the Key Usage attribute of the certificate must be Digital Signature. For encryption and decryption, the Key Usage attribute of the certificate must be Data Encipherment or Key Encipherment. You can verify the Key Usage attribute by double-clicking the certificate, clicking the Details tab in the Certificate dialog box, and checking the Key Usage field."

    I have noticed that the certificate that is not showing in BTAdmin, does not have field "Key Uasge", but other one does have and its value is "Digital Signature, Key Encipherment (a0)". Is there any way to configure that "not working" certificate, so that I can select it in BTAdmin or this is dead end?

    Thanks in advance,

    TG

    Wednesday, November 13, 2013 2:12 PM

Answers

  • Sorry no.  The certificate is generated with any specific attributes and that's it.

    You will have to generate/request a new cert with the correct Key Usage.

    Wednesday, November 13, 2013 3:22 PM

All replies