locked
401 Unauthorized when using URL RRS feed

  • Question

  • I just installed a Sharepoint server and I'm trying to allow access from the internet.   However, I just added a DNS entry on our network which points sharepoint.domain.com to the server's IP address.  When I enter the URL in a browser, I get a 401 Unauthorized error message.  But when I just enter the server name (http://sharepoint), I get right in.   Is this an IIS issue or something else?
    Friday, November 13, 2015 8:48 PM

Answers

  • Hi,

    Totally agree with Trevor here. and in the other hand, Always try to follow Hostheader Web Application Creation.

    1. Just Create a New DNS HostAAA points to your WFE Server/Or Load Balancer.

    2. Create a new Web Application using the above HostAAA record as the Hostheader.

    This Process will add whatever the necessary Mappings (In IIS and SharePoint Access Mapping Zones) during the Web App Creation. And it's straightforward and basically nothing to troubleshoot.

    ----------------------------------------------------------------------------------------

    Please mark as answer or vote as helpful.


    Saturday, November 14, 2015 2:22 AM
  • Never, ever manipulate authentication settings via IIS. It's unsupported and will not replicated to other servers.

    In addition, Kerberos will not work over the public Internet as the client cannot contact the KDC to get a Kerberos token. NTLM must be used (or a pre-auth system must be in place in front of SharePoint).


    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, November 13, 2015 10:00 PM

All replies