locked
COM DLL Management in IIS 6.0 RRS feed

  • Question

  • User1628746328 posted
    Hello there. I'm still having some problems configuring a server running Windows 2003 Server with IIS 6.0. I have a couple of Crystal Reports DLL's running in a Classic ASP application, and I've placed the DLL's in the Component Services Manager. The problem is that it looks as though when the COM object instantiation is being fired, I'm getting an error saying that there is an OBJECT REQUIRED. This is working fine in an XP Pro environement, which kind of leads me to beleive it might be an II6 thing <?> Thanks. Doug
    Wednesday, May 19, 2004 1:57 PM

All replies

  • User-1122936508 posted
    a) please outline the exact steps you took to "install" these .dlls b) please outline the exact method you are attempting to invoke them (eg provide some code) c) please provide the exact error message that you are seeing. d) if you have any documentation from Crystal on how this should be setup on IIS 6.0, then please post links to that to, so we can review it. Cheers Ken
    Wednesday, May 19, 2004 9:24 PM
  • User169445262 posted
    I'm having the same type of problem with a DLL for a shopping cart ASP application. I cannot figure out how to get IIS 6.0 to allow even the simplest ASP script to create the object.
    Tuesday, June 22, 2004 12:45 PM
  • User1365816255 posted
    Hey~ What happens if you use - <% Response.Write Now() %> If you are using COM Objects, then they are simple ASP pages. Have you enabled ASP in the Web Services Extensions? (First step) ... Also, backing what Ken said, you aren't giving any details to what the browser is returning vs. what the IIS Log files say...Check them @ %windir%\system32\logfiles Thanks, ~Chris (MSFT) Web Platform Supportability Lead
    Tuesday, June 22, 2004 9:43 PM