locked
System.Web.Helpers missing error RRS feed

  • Question

  • User-1917139049 posted

    I've been merging some branches and running/testing web app locally after each merge. During one testing Visual Studio 2015 crashed and I restarted it, but after a while (maybe immediately) I haven't been able to run my application anymore.
    Now I can't run any commit of my application from any branch.

    I got error message in browser as shown:

    Server Error in '/' Application.


    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Could not load file or assembly 'System.Web.Helpers, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Source Error: 

    Line 16:     <compilation debug="true" targetFramework="4.5.2">
    Line 17:       <assemblies>
    Line 18:         <add assembly="System.Web.Helpers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Line 19:         <add assembly="System.Web.WebPages, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Line 20:         <add assembly="System.Web.Mvc, Version=3.0.0.1, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />


    Source File: D:\Web_solution\Portfolio\Fehirde.Portfolio.Domain\web.config    Line: 18 

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Web.Helpers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.

    === Pre-bind state information ===
    LOG: DisplayName = System.Web.Helpers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
     (Fully-specified)
    LOG: Appbase = file:///D:/Web_solution/Portfolio/Fehirde.Portfolio.Domain/
    LOG: Initial PrivatePath = D:\Web_solution\Portfolio\Fehirde.Portfolio.Domain\bin
    Calling assembly : (Unknown).
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: D:\Web_solution\Portfolio\Fehirde.Portfolio.Domain\web.config
    LOG: Using host configuration file: C:\Users\Worker\Documents\IISExpress\config\aspnet.config
    LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
    LOG: Redirect found in application configuration file: 1.0.0.0 redirected to 3.0.0.0.
    LOG: Post-policy reference: System.Web.Helpers, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    LOG: Attempting download of new URL file:///C:/Users/Worker/AppData/Local/Temp/Temporary ASP.NET Files/root/807b510b/48289540/System.Web.Helpers.DLL.
    LOG: Attempting download of new URL file:///C:/Users/Worker/AppData/Local/Temp/Temporary ASP.NET Files/root/807b510b/48289540/System.Web.Helpers/System.Web.Helpers.DLL.
    LOG: Attempting download of new URL file:///D:/Web_solution/Portfolio/Fehirde.Portfolio.Domain/bin/System.Web.Helpers.DLL.
    LOG: Attempting download of new URL file:///D:/Web_solution/Portfolio/Fehirde.Portfolio.Domain/bin/System.Web.Helpers/System.Web.Helpers.DLL.
    LOG: Attempting download of new URL file:///C:/Users/Worker/AppData/Local/Temp/Temporary ASP.NET Files/root/807b510b/48289540/System.Web.Helpers.EXE.
    LOG: Attempting download of new URL file:///C:/Users/Worker/AppData/Local/Temp/Temporary ASP.NET Files/root/807b510b/48289540/System.Web.Helpers/System.Web.Helpers.EXE.
    LOG: Attempting download of new URL file:///D:/Web_solution/Portfolio/Fehirde.Portfolio.Domain/bin/System.Web.Helpers.EXE.
    LOG: Attempting download of new URL file:///D:/Web_solution/Portfolio/Fehirde.Portfolio.Domain/bin/System.Web.Helpers/System.Web.Helpers.EXE.
    

     


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2046.0

    Thursday, June 1, 2017 3:25 PM

Answers

  • User-1917139049 posted

    Solved.
    Somehow other project has been set up as a startup one. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 1, 2017 4:45 PM