locked
Cannot connect to "Device" in Windows Phone Developer Power Tools (8.1)

    Question

  • Hi, after a while of bliss, the Windows Phone Developer Power Tools (8.1) will not Connect to my Device Lumia 630 anymore. The os on the 630 is 8.10.12397.895.

    When I hit the "Connect" button, it changes its label to "Connecting", and after a while the "Phone Tools Update Pack" dialog shows, indicating the phone update needs to be installed (and it already is). When I try to install, there is an error: "The update operation did not succeed. You can press Rescan to try reconnecting to the Device" "The Exceptioncode and error Message is: 0x80004003 - Object Reference not set to an instance of an Object." Btw, I'm able to debug and do performance analysis for apps remotely at the Device. Also the phone shows up in file Explorer, and my Developer Account is ok. Phone is Developer unlocked as well. 


    UPDATE: I switched to a non-corporate Wi-Fi on the Laptop Connected to the Phone, and I was able to make the Connection.
    Wednesday, September 17, 2014 12:49 PM

All replies

  • Hi Jan,

    Yes, I can repro your problem with the Lumia 920 device. But I need some more time to check what happened. If I get something useful, I will follow a post to let you know the result.

    Thank you for understanding.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 18, 2014 8:09 AM
    Moderator
  • I aso met this problem on Nokia 920. It is very strange. Sometimes it turns normal. My friend installs "Remote Tools for Visual Studio 2013" , launches it and then uses that windows phone power tools. And it works. Don't know what happened. You could have a try.
    Friday, September 19, 2014 1:40 AM