none
Calendar and current events views in Calendar list are missing views RRS feed

  • Question

  • I noticed something rather strange.  I created a Calendar list in SharePoint 2013, and out of the box they create 3 views for you, which are "Calendar" (the default), "All Events", and "Current Events".

    Now, what's strange is that the "Calendar" and "Current Events" views, do not contain the normal view shortcuts on the page.  The "All Events" does though:

    The default "Calendar" view, and the "Current Events" view however force you to click on the ribbon and access the views that way.  It does not have the normal location of views (like the All Events view above):

    Here is the "Current Events" view (see right below), you can only upload 2 photos now per message):

    This is very confusing for end users, the transition between views is giving such a different experience.  Not quite sure I understand why this works this way.

    Does anyone know

    Monday, February 23, 2015 10:19 PM

Answers

  • Hello

    That's the default behavior of SharePoint 2013 which we cant change much despite of this fact it shows some degree of unevenness. But as a workaround you can do the following steps:

    1]Go to the default calendar view

    2]Edit Page

    3]Edit Calendar Webpart

    4]Under List Views->Tool Bar Type select Show Tool Bar option.

    5]Click OK and save the page and your Calendar View will look something like this which will give you the option to change the views.

    Please mark it answer or helpful if it really helps :)

    -Vikram

    • Proposed as answer by VikramSamal Tuesday, February 24, 2015 12:30 AM
    • Marked as answer by Rebecca Tu Wednesday, March 4, 2015 5:13 AM
    Tuesday, February 24, 2015 12:26 AM

All replies

  • Here is the "Current Events" view:

    Monday, February 23, 2015 10:19 PM
  • Hello

    That's the default behavior of SharePoint 2013 which we cant change much despite of this fact it shows some degree of unevenness. But as a workaround you can do the following steps:

    1]Go to the default calendar view

    2]Edit Page

    3]Edit Calendar Webpart

    4]Under List Views->Tool Bar Type select Show Tool Bar option.

    5]Click OK and save the page and your Calendar View will look something like this which will give you the option to change the views.

    Please mark it answer or helpful if it really helps :)

    -Vikram

    • Proposed as answer by VikramSamal Tuesday, February 24, 2015 12:30 AM
    • Marked as answer by Rebecca Tu Wednesday, March 4, 2015 5:13 AM
    Tuesday, February 24, 2015 12:26 AM
  • You have to make this change on every view page, otherwise it only shows on the default page.

    David

    Thursday, May 12, 2016 1:45 PM