locked
Unexpected error Detected. Check the Test Output Pane for Details RRS feed

  • Question

  • I am getting an error after I added a unit test project to my solution.

    It compiles fine, the unit tests run fine, but I get the error in the lower left status bar of the below screenshot. The test pane in teh output refers to an issue "Archive file cannot be size 0"

    I cant figure out what is causing it

     Thanks in advance for any thoughts.

     


    • Edited by z1plock Monday, March 10, 2014 6:59 PM
    Monday, March 10, 2014 6:57 PM

Answers

  • Hi z1plock,

    Sorry for my misunderstanding about this issue.

    If possible, please set the test project as the startup project, and then right click this project, clean and rebuild it. Please check the Output window again, to make sure that whether you get any other useful message, please change the “Show output from:” to “build” option, you could change it like the following screen shot.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 12, 2014 6:16 AM

All replies

  • Hi z1plock,

    How did you add this project to a new solution?

    Like the following screen shot, it seems that you add some hidden files to this soltuion, could you move/delete them in your project folder? Then clean and rebuild this test project in your Solution Explorer. Check it again.

    If it still has this issue, my suggestion is that you could create a new test project, and then copy the test project files to this new project, run it again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 11, 2014 8:39 AM
  • I just did an add new project.  The files that you see are because I always select the show all files icon in the solution explorer. They are part of every project (except for the test output, which is specific to the unit test project)

    Yes, I have deleted these  and did a clean/rebuild. But as these are part of the project, they get recreated on compile

    Hi z1plock,

    How did you add this project to a new solution?

    Like the following screen shot, it seems that you add some hidden files to this soltuion, could you move/delete them in your project folder? Then clean and rebuild this test project in your Solution Explorer. Check it again.

    If it still has this issue, my suggestion is that you could create a new test project, and then copy the test project files to this new project, run it again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, March 12, 2014 2:01 AM
  • Hi z1plock,

    Sorry for my misunderstanding about this issue.

    If possible, please set the test project as the startup project, and then right click this project, clean and rebuild it. Please check the Output window again, to make sure that whether you get any other useful message, please change the “Show output from:” to “build” option, you could change it like the following screen shot.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 12, 2014 6:16 AM
  • Just an FYI this issue was never resolved and still persists today,
    Friday, May 16, 2014 7:33 PM