none
Azure Storage Explorer: Error creating blob 11: The remote server returned an error: (400) Bad request

    Question

  •  

    When I created Blob in the Azure Storage Explorer, it always threw this error message:Error creating blob 11: The remote server returned an error: (400) Bad request,why this happens?

    Thanks in advance.

    Tuesday, May 31, 2016 2:20 AM

All replies

  • Hi,

    Thank you for posting here!

    If you attempt to create a container or blob with a name that violates naming rules, the request will fail with status code 400 (Bad Request).

    A blob name must be conforming to the following naming rules:

    • A blob name can contain any combination of characters.

    • A blob name must be at least one character long and cannot be more than 1,024 characters long.

    • Blob names are case-sensitive.

    • Reserved URL characters must be properly escaped.

    • The number of path segments comprising the blob name cannot exceed 254. A path segment is the           string between consecutive delimiter characters (e.g., the forward slash '/') that corresponds to the             name of a virtual directory.

    For more information, refer below link:

    https://msdn.microsoft.com/en-us/library/azure/dd135715.aspx?f=255&MSPPError=-2147217396

    Regards,

    Vikranth S.

    Please remember to click "Mark as Answer" on the post that helps you, this can be beneficial to other community members reading the thread. And Vote as Helpful.

    Tuesday, May 31, 2016 10:06 AM
    Moderator
  • Hi vikranth,

    I created blob in Azure Storage Explorer, and its name is "11", does it violate naming rules?

    I don't think this is the root of this issue.

    Any other hints?

    Regards,

    Juzer

    Tuesday, May 31, 2016 1:54 PM
  • Hello,

    Are you using “General-purpose storage account” or “Blob storage account”?

    You can see in the storage account pane; under the name of the account it should show as either Blob or General. See below.

    If it is a blob storage account, the error may occur:

    • The version of the storage explorer. The new version is available @ http://storageexplorer.com/ which supports blob storage accounts.
    • To upload page blobs (not supported yet)

     

    Regards,

    Vikranth S.

    Thursday, June 9, 2016 9:03 AM
    Moderator
  • Hello Juzer,

    As Vikranth mentioned above, can you try with the latest Storage Explorer (irrespective of the account type) and see whether this resolves your problem.

    Thanks,

    Sri

    Thursday, June 9, 2016 5:07 PM