locked
503 service unavailable, eventid 2282 RRS feed

  • Question

  • User-407426236 posted

     Hi,

     First of all, I am unsure if I posted this question into the right forum. I was seriously doubting between this one and the 64 bit Native Mode one. If I posted it in the wrong one, please accept my apologies.

     Today, all of the sudden, when I tried to load up a page on my local server (localhost), I received a "503 service unavailable error". 

     I checked many different websites and solutions, but none was suitable for my problem, so I kind of hope you guys are able to help me out here.

     The event viewer gives the following error:

    The Module DLL 'C:\Windows\System32\inetsrv\custerr.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

    Event ID: 2282

     The link they give in the error message links to iis.net, but no specific document is given. I figure, also because of the error message, that it has something to do with the 64 bit configuration, but what, I don't know.

     Like said, it happened all of the sudden. I haven't had any problems in about a year, and now, out of the blue, the 503 error message pops up. When I change the application pools to 32 bit (I only have ASP.NET 1.1 and DefaultAppPool listed there), it does give me the standard IIS7 welcome page, but none of my websites (which are basically placed in subdirectories) seem to work (maybe because they have been made in PHP?), instead, I receive a 403.14 Forbidden or a 404.17 Not Found message (depending if I type the URL of a directory, or a direct file.. it is able to open static HTML pages under 32 bit apparently).

     Thing is, like said, I never touched or changed anything weird here. I once set it up to work with PHP5 and MySQL5.1 on my Vista 64 bit machine, and it always worked like a charm. But now, all of the sudden, this problem pops up.

    My configuration is as follows:

    Does anyone have any ideas? Thanks in advance :)

    Thursday, January 7, 2010 2:26 AM

All replies

  • User-2064283741 posted

     

    CustomErrorModule

    Sends default and configured HTTP error messages when an error status code is set on a response.

    Inetsrv\Custerr.dll


    Have you changed anything to do with this?
    Thursday, January 7, 2010 8:10 AM
  • User-407426236 posted

    Have you changed anything to do with this?
     

    Hi, thank you for your reply. I just checked to make sure, but as far as my memory goes, I never changed anything there.

     

     

    Edit: one of the things I did change a while ago (after this it still worked perfectly though) were a few URL rewrite rules.. I disabled these after a while and after that the IIS server was still working ok.These URL rewrite rules were also only there for one directory, other directories were not affected by it like they are now.

    Other than that I don't recall any changes in the IIS system.

    Thursday, January 7, 2010 3:16 PM
  • User744767459 posted

    Hi,

    Please check the possible resolutions in the following article:

    Event ID 2282 — IIS Worker Process Availability
    http://technet.microsoft.com/en-us/library/cc735139(WS.10).aspx

    Tuesday, January 12, 2010 4:22 AM
  • User-407426236 posted

    Hi,

    Please check the possible resolutions in the following article:

    Event ID 2282 — IIS Worker Process Availability
    http://technet.microsoft.com/en-us/library/cc735139(WS.10).aspx

     

    Hi,

     Thank you for your answer. I looked on that webpage and did what was said there, for as far as I could understand it all.

     However, when I load the err.exe utility like said in there, I get the following message:

     C:\Err>err 000000c1
    # for hex 0xc1 / decimal 193 :
      SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION                       bugcodes.h
      SQL_193_severity_15                                           sql_err
    # The object or column name starting with '%.*ls' is too
    # long. The maximum length is %d characters.
      ERROR_BAD_EXE_FORMAT                                          winerror.h
    # %1 is not a valid Win32 application.
    # 3 matches found for "000000c1"

     

    However, I have no idea what to do next. I entered some of the lines in a search engine to see what that came up with. I found a few other people with similar problems, but their solutions unfortunately didn't work for me.

    (for example: 

    http://social.msdn.microsoft.com/Forums/en-SG/netfx64bit/thread/ead4e0be-9f1f-401b-8c9b-038eb51eb042

    and

    http://blogs.msdn.com/rakkimk/archive/2007/06/09/problems-with-32-bit-asp-net-2-0-dlls-on-a-windows-2003-server-64-bit.aspx

    are both similar but they didn't work in my situation).

     

     Do you have any idea what I can do next? Thanks in advance :)

    Wednesday, January 13, 2010 6:25 AM