none
Update 2

    Question

  • Since the new update 2 for Visual Studio, the snippet now needs to be identified by the title, this makes the whole point of the custom snippets pointless. i.e. custom lists jobs\list = List in jobs folder is the same as columns\list = List in columns folder. Now when you use the intellisense it will show the snippet that first matches the title of List, this will usually be a code snippet that is totally irrelevant. Why do you constantly make something that works and then break it?

    Is there a fix, a workaround. Or will this remain another pointless feature...

    Cheers Pete 

    Wednesday, April 27, 2016 9:12 AM

All replies

  • Hi Pete,

    Do you mean you have two list file in both jobs folder and columns folder in your project and when you use them in a same code file, it will matches the title.list which as below image shows? If misunderstanding, please feel free to let me know and provide some screenshot and detailed steps to help me reproduce this issue.

    I also find this issue is annoying and I don't find such settings for this problem. I suggest you submit this problem to Visual Studio Connect and share the feedback link here. I will vote it and it also can let other communities to vote and add comments for this issue.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 28, 2016 7:05 AM
    Moderator
  • Hi... Thanks for the speedy response...

     Sorry... I was in a little bit of a rage and didn't really explain myself very well, as this has made all the snippets that we use on a daily basis, useless.

    I use customised snippets a lot for SSDT within VS 2015, and have built hundreds to carry out SQL work. The issue has come about since update 2, which now no longer can distinguish between the different titles within the snippet xml. As an example we would setup a heap of snippets in a job folder and heap of snippets in a table folder, so forth... and so forth... adding the folders to the code snippet manager allowed you to build up the structure of how they were displayed i.e.

    Under SSDT you could have the following:

    jobs\list

    columns\list

    Since the changes to the snippets to improve the performance in update 2, it seems to no longer distinguish between the two different 'list' titled snippets as in the example. It will give the snippet code for the first one that matches 'list' in the title tag.

    There maybe a workaround or something I'm missing here, but the functionality seems to have changed, and there does not seem to be a way to rectify.

    Cheers in advance Pete

    Thursday, April 28, 2016 9:56 AM
  • Hi Pete,

    Could you please provide a detailed step about what's SSDT project and how to setup a heap of snippets in jobs/columns folder? Since I'm not familiar with SSDT project, I need to try reproduce your problem to find out whether this is a problem related to Update 2 or some settings in Visual Studio. Thanks for your understanding.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 29, 2016 2:51 AM
    Moderator
  • Hi Pete,

    We need to know more detailed information to help us reproduce this issue in our side. We are waiting for your response.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, May 04, 2016 10:18 AM
    Moderator
  • Hi Weiwei,

    It is as simple as explained, if you create a snippet for listing columns and entitle it 'list' and save it in a columns folder, and create a snippet for listing tables and entitle it 'list' and save it in a tables folder. When you add both folders to the snippet manager i.e. add folder tables, and add folder for columns. The intellisense when you select tables or columns and then list, does not show the correct code for the one selected. As it can no longer distinguish between the two. It simply use to work and now does not, I believe this was part of the work carried out to improve the performance of the snippets in update 2.

    Cheers Pete

    Thursday, May 05, 2016 11:12 AM
  • Hi Pete,

    Thanks for your detailed description and I found the same problem in Visual Studio 2015 Update 2. So I suggest you submit this problem to Visual Studio Connect and then share the feedback link here. I will vote it and it also can let other communities who has the same problem to vote and add comments for your feedback.

    I think the report team experts will treat this problem seriously and if any update, they will send us mail for this issue.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, May 06, 2016 2:50 AM
    Moderator
  • Hi Weiwei,

    I've logged a bug report, tried to paste in feedback link but wont let me due to requirement of account verification.

    Thanks for all your help...

    Cheers Pete

    Friday, May 06, 2016 4:18 PM
  • Hi Pete,

    Thanks for your feedback for Visual Studio product. Please share the feedback link as common text, which we can copy this text to browser to open it. Thanks.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 09, 2016 2:54 AM
    Moderator
  • http://connect.microsoft.com/VisualStudio/Feedback/Details/2675089
    Monday, May 09, 2016 8:16 AM
  • Hi Weiwei,

    Feedback link for bug report above.

    Cheers Pete 

    Monday, May 09, 2016 8:17 AM
  • Hi Pete,

    Thanks for your feedback link and I have vote it.

    Please mark your feedback link reply as answer, which can let other communities who has the same problem to vote and add comments for your feedback.

    And I find the report team expert has response your feedback, please provide detailed information to help the team expert to reproduce your problem and they will figure out whether this is a bug or default design for Update 2.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 09, 2016 8:32 AM
    Moderator
  • Hi Weiwei,

    Thanks for all your efforts, I've uploaded a document to the bug report site, which it says was successful. But still nothing has appeared on the attachments. I cant really keep spending time on this. Is there anyway that you can chase your end in regards to reproducing this issue. If there is a way that you can find out if they've picked up the attachment, that would be something.

    Cheers Pete

    Wednesday, May 11, 2016 8:34 AM
  • Hi Pete,

    If you can't add attachment file for your feedback, I suggest upload the file to OneDrive and share a public link. Then add the link as a comments for your feedback.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 12, 2016 2:01 AM
    Moderator
  • Says its uploaded and that it might not appear straight away, but still hasn't appeared in the attachments.

    I'll wait it out and see if they come back on it...

    Cheers Pete

    Thursday, May 12, 2016 1:25 PM
  • Hi,

    Is there any information regarding the progress on this fault? As I cant seem to comment on the connect site for this, to ask for more information.

    Cheers Pete

    Tuesday, May 31, 2016 2:14 PM
  • Hi Pete,

    I have submit the problem that can't add attach files and comments for the feedback. And I past this thread link in the comment.

    Please try share the information that report team experts asked to OneDrive and then share a public link here, which can let them get the information for this issue.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, June 01, 2016 4:59 AM
    Moderator