none
provider is not regitered on your local machine RRS feed

  • Question

  • Hi all

    I.m trying to connect to excel from a vb.net app,

    I have a problem to define the suitable provider,

    I tried "Microsoft.Jet.OLEDB.4.0" I recieved a message "Provider Microsoft.Jet.OLEDB.4.0 is not registered on your local machine"

    when I change the provider to ace.12.0 , I recieved the same message

    Any help????


    SqlDream

    Friday, March 15, 2013 9:33 AM

All replies

  • What operating system are you using?

    The Jet is located in the folder below and is part of Windows and must be in this folder.  It is automatically registered when windows is installed.  If you can't get jet engine then there is a problem with your windows installation or Your application has an error.

    C:\WINDOWS\system32\msjet40.dll

    The conneciton string should look like the following VBnet

    ConnectStr = _
       "Provider=Microsoft.Jet.OLEDB.4.0;" & _
       "Data Source=" & Folder & FName & ";" & _
       "Mode=Share Deny None;"

    C#

    ConnectStr = _
       "Provider=Microsoft.Jet.OLEDB.4.0;" +
       "Data Source=\" + Folder + FName & \";" +
       "Mode=Share Deny None;"


    jdweng

    Friday, March 15, 2013 10:41 AM
  • If you are running 64-bit Windows then you probably need to change the Platform option (Build...Configuration Manager...) in your project to x86. There is no 64-bit version of the Jet OLEDB Provider so the app cannot be compiled with the Any CPU or x64 Platform when running 64-bit Windows. It sounds like you have the 32-bit version of ACE installed as well.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, March 18, 2013 12:37 PM
  • Hi,

    refer to this thread for JET OLEDB also you may need to look into the connectionstring of your application.


    Manish Patil http://patilmanishrao.wordpress.com Posting is provided AS IS with no warranties, and confers no rights.

    Manish Patil's Blog

    ↑ Grab this Headline Animator

    Tuesday, March 19, 2013 8:21 AM