none
Error Sys.WebForms.PageRequestManagerServerErrorException when using reportviewer + AjaxTookKit RRS feed

  • Question

  • Hi all,

    I am creating a report system using ReportViewer plus some AjaxTookKit controls, i am running fine in local pc (in debug mode), but after I published onto server and view it in browser, I keept get the error and some controlls not working.

    The Webpage error details:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E; Tablet PC 2.0)
    Timestamp: Thu, 24 Oct 2013 09:06:38 UTC


    Message: Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 500
    Line: 2
    Char: 69963
    Code: 0
    URI: http://s01a346/SkyNetReport/ScriptResource.axd?d=5dK_Vn3CH-R74r-viHZMmoA1ppSyNV0-UUebBHfDTi5Kf3TkF-tZtwTf5pJPdjnf0&t=153abac5

    I searched through internet and tried beow options but no lucky:

    - Disable EventValidation in the web form

    - enablevalidation=false; validationrequest=false;(in page tag)

    Pls help!

    Thursday, October 24, 2013 9:41 AM

Answers

  • As this forum supports .NET Framework setup, you can check the integrity of .NET Framework versions on the server with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    After you run the tool with the applicable .NET version selected, check the last few lines of the tool log. If the test app failed, the framework needs to be repaired on the server.

    If the test app ran successfully, the issue is not with the .NET Framework and you should get help with your web app in a suitable forum here:

    http://forums.asp.net/

    Thursday, October 24, 2013 2:27 PM