none
Copy-pasting within tables in Expression Web RRS feed

  • Question

  • Up to now, whenever I marked a row in a table in Expression Web 4 and copied it, when I clicked on the last cell of a row, the program would insert the copied row as a new row below that position. This didn't only work with rows, but with any cell blocks. Today I must have somehow accidentally changed this. Now, whenever I mark a row and copy it, it only copies the text contained in the row, and inserts the text into the cell, regardless of how many cells were actually copied. I tried to determine what went wrong and to restore the original settings, but to no avail. This is extremely inconvenient, could someone please help me and tell me how to reset the program?

    Thursday, March 22, 2012 10:00 PM

All replies

  • I don't know of any settings that change how EW handles copying and pasting.
    Thursday, March 22, 2012 10:14 PM
  • I've noticed that it's more than just that. I tried copying with WORD and other programs, whatever I copy now, only the pure text is copied, not the format. I must have changed it for my whole system (I'm using Windows 7). Rebooting doesn't reset its bevahiour. Any idea how I can change it back?
    Thursday, March 22, 2012 11:30 PM
  • Apparently you missed noting the purpose of this forum on your way in. Here's a reminder...

    Expression Web and SuperPreview

    Questions and discussions regarding Expression Web, the professional design tool for creating modern, standards-based sites that deliver superior quality on the web.

    Get it now?

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Thursday, March 22, 2012 11:57 PM
  • I originally thought that I had a problem with expression web, that's why I started this thread here. I have since noticed, that the problem is with Windows itself, not with Expression Web.
    Thursday, March 22, 2012 11:59 PM
  • " I must have changed it for my whole system (I'm using Windows 7). Rebooting doesn't reset its bevahiour. Any idea how I can change it back?"

    Try finding a Win 7 forum.  :)

    Friday, March 23, 2012 1:59 AM
  • I've noticed that it's more than just that. I tried copying with WORD and other programs, whatever I copy now, only the pure text is copied, not the format. I must have changed it for my whole system (I'm using Windows 7). Rebooting doesn't reset its bevahiour. Any idea how I can change it back?

     Use system restore and pick a restore point that predates the issue.

    Expression Web MVP

    Friday, March 23, 2012 12:28 PM
  • Hi,

    I had the same problems. Uninstalling Skype Click-to-Call fixed it.

    Cheers Rob

    • Proposed as answer by bgfun Sunday, June 17, 2012 3:15 AM
    Wednesday, March 28, 2012 7:39 AM
  • Hi Rydeen,

    I don't know what happened to your copy and pasting.

    But i can tell you an idea here, is that when you design a table in word docx and you paste in notepad as an example, you will lose the design, you will see that you pasted only the text in the table.

    But if you tried to paste the table in html view, you will have the design you did in the word docx as you see in the below screen shot, created the table in word and copied it and pasted it in EW4 in HTML View


    Mai Omar Desouki | Software Consultant | Infusion | MCP, MCTS, MCPD, MCITP, MCT Microsoft Certified Trainer & MCC Microsoft Community Contributor | Email: mai_omar_86@live.com | Blog: http://moresharepoint.wordpress.com

    Wednesday, March 28, 2012 11:10 AM
  • No. Never paste directly from Word into Expression Web.

    Look at that code. It's full of garbage settings that mean nothing to a browser:
    width: 239.4pt; (points are for print--they mean nothing to browsers)
    mso-background-themecolor: accent6; (meaningless)
    mso-background-themeshade: 216; (meaningless)
    padding: 0in 5.4pt 0in 5.4pt (again, inches and points mean nothing to a browser trying to display on a monitor)
    <o:p>&nbsp;<o:p> (What's the point of doing that every time? It's just a space.) 

    Some of the Word garbage code might display in Internet Explorer (since it's an MS product), but it will not display in other browsers.

    Never, ever paste directly from Word into EW. Do it properly.


    Titanic, the movie, as CSS:

    @mixin iceberg {
         float: none;
    }

    #titanic {
         @include iceberg;
    }

    Wednesday, March 28, 2012 12:20 PM
  • Pasting directly into code view isn't something I'd tried but when I do is get the content of the cells NOT the table tags.

    My WordPaste Add-In does a reasonable job of cleaning up Word HTML. It's not 100% but works perfectly in the majority of cases, dependant on how complex the formatting in Word is.

    See http://gallery.expression.microsoft.com/WordPasteSP2


    Ian Haynes

    EW - V4 Add-Ins
    EW - Resources, hints and tips
    EW - Design for the Mobile Web

    Wednesday, March 28, 2012 12:31 PM
  • Worked like a charm!! So nice to be able to copy tables, rows, etc and keep all the formatting.
    Sunday, June 17, 2012 3:32 AM