locked
Access Denied Error RRS feed

  • Question

  • I know there is another thread like this currently, but they are getting into HealthVault at least partially. We are not getting in at all.

    the Troubleshooter is showing no issues:

    ==========================================================================
    Application ID and certificate information

    This section shows the application ID contained in the web.config file, and information about the certificates that this process can access.
    Application Id    813C11EA-1B9C-11DD-AB99-FEB456D89593
    Certificate    Found: WildcatApp-813C11EA-1B9C-11DD-AB99-FEB456D89593
        Private key accessible
    Server Access Information

    This section shows the results of trying to access Microsoft.com and the consumer and developer HealthVault servers.
    Microsoft.com    Connection successful
    ShellUrl    Connection successful
    HealthServiceUrl    Connection successful
    ===========================================================================

    But I still get Access Denied:

    2008-08-21 07:38:53,671 [1] ERROR Spinn.Dao.BaseDao (null) - Exception occured connecting to HV:
    Microsoft.Health.HealthServiceAccessDeniedException: Access is denied.
       at Microsoft.Health.EasyWebRequest.WaitForCompletion()
       at Microsoft.Health.EasyWebRequest.Fetch(Uri url)
       at Microsoft.Health.EasyWebRequest.Fetch(Uri url, IEasyWebResponseHandler customHandler)
       at Microsoft.Health.HealthServiceRequest.ExecuteInternal()
       at Microsoft.Health.AuthenticatedConnection.ExecuteRequestWithRetry(HealthServiceRequest request)
       at Microsoft.Health.HealthServiceRequest.Execute()

    I've tried with both the IUSR_* account and a local user with admin privileges.
    Thursday, August 21, 2008 4:29 PM

Answers

  • Have you been able to get hello world up and running? If not, I'd suggest that you start by getting that:

     

    1) Working through visual studio

     

    and

     

    2) Working through IIS

     

    before you start with your own application.

    Thursday, August 21, 2008 5:56 PM
  • Are you using the same server for production and PPE?

     

    This might be helpful:

    http://blogs.msdn.com/healthvaultfaq/archive/2008/06/05/my-app-was-working-before-but-now-i-get-access-denied.aspx

    regards,
    Vaibhav
    Thursday, August 21, 2008 8:23 PM

All replies

  • Have you been able to get hello world up and running? If not, I'd suggest that you start by getting that:

     

    1) Working through visual studio

     

    and

     

    2) Working through IIS

     

    before you start with your own application.

    Thursday, August 21, 2008 5:56 PM
  • yes. i've been doing this for a bit.
    this is our production server. our app was approved to go live, and i'm getting access denied.

    i have tried direct email and phone support, to no avail. if someone could just take a quick look, that would be helpful
    Thursday, August 21, 2008 7:47 PM
  • Are you using the same server for production and PPE?

     

    This might be helpful:

    http://blogs.msdn.com/healthvaultfaq/archive/2008/06/05/my-app-was-working-before-but-now-i-get-access-denied.aspx

    regards,
    Vaibhav
    Thursday, August 21, 2008 8:23 PM
  • No. We have 2 different servers - one for production, one for dev, each on a separate IP address.
    Although, they are both running on the same physical machine (vmware instances).

    The App Manager on Prod shows just one key, with the right appID and right privileges.

    I checked for the hidden certs as well. Just the one.
    Thursday, August 21, 2008 9:20 PM