locked
Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive. RRS feed

  • Question

  • User-228998149 posted

    I have developed the website in netframe 4.0 and tried using web hosting connection string,

    I have uploaded the website on friends hosting server with his ipaddress it was working 100% ok

    and my own web hosting service ip address eetc in my web config file
    its running fine on my local server with the web config of my hosting server

    but as soon as i deployed and upload on my hosting server
    I got this error

    Server Error in '/' Application.
    
    Configuration Error
    
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
    
    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.
    
    Source Error: 
    
    
    Line 19:   
    Line 20:     <httpRuntime maxRequestLength="1048576" />
    Line 21:     <compilation debug="true" targetFramework="4.0">
    Line 22:       <assemblies>
    Line 23:         <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    
    Source File: C:\Inetpub\vhosts\chulbul.net\httpdocs\web.config    Line: 21 
    
    Version Information: Microsoft .NET Framework Version:2.0.50727.5472; ASP.NET Version:2.0.50727.5471


    all this is running fine on my computer and also on friend wensite but not on mine 

    I have uploaded the database as .bak in my server and also with the user role but not woking both .bak and user role with the hosting ip address is working on my comuter also

    need help in this matter
     

    Tuesday, August 13, 2013 7:01 AM

Answers

  • User-1716253493 posted
    Your app still configured as net framework 2.0 application. You need to configure application pool to use net framework 4
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 13, 2013 7:15 AM
  • User311508580 posted

    Hi Tahir,

    You need to ask your hosting provider to setup .net 4 for you. If I see the error, the app pool still using .net 2.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 13, 2013 11:44 PM

All replies

  • User-1716253493 posted
    Your app still configured as net framework 2.0 application. You need to configure application pool to use net framework 4
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 13, 2013 7:15 AM
  • User311508580 posted

    Hi Tahir,

    You need to ask your hosting provider to setup .net 4 for you. If I see the error, the app pool still using .net 2.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 13, 2013 11:44 PM
  • User218309205 posted

    Try removing targetFramework attribute and check.

    <compilation debug="true" targetFramework="4.0">
    Wednesday, August 14, 2013 3:23 AM
  • User-228998149 posted

    Now my problem is solved 

    it was app pool Issue i chnaged it to Net fram 4.0 and also tell my hosting providers to change it

    I installed IIS
    and change its setting to 4.0  

    Wednesday, August 14, 2013 1:44 PM