locked
Using Direct3D stereoscopic 3D sample, my display stays in 3D mode.

    Question

  • Hi there,
    I'm not sure if anybody has encountered this problem yet because I have not found any blogs about this. After running this sample, my display stays on 3D mode even after exiting the application. Is it just me or is this a known problem. How can I disable the 3D and go back to 2D?
    I hope someone can help me out.

    Thanks!

    Thursday, September 20, 2012 3:33 AM

All replies

  • Hi again!

    It looks like not many are using the 3D functionality of Win8 yet.

    Anyway, just some additional information regarding my problem. The code below shows how to enable the 3D mode on the display by setting up the swapchain descriptor.

           

    // Allocate a descriptor.

    DXGI_SWAP_CHAIN_DESC1swapChainDesc = {0};

    swapChainDesc.Width = 0;                                    

    // Use automatic sizing.

    swapChainDesc.Height = 0;

    swapChainDesc.Format =

    DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.

    swapChainDesc.Stereo = true;    <<<<<<<------------ SET 3D MODE

    swapChainDesc.SampleDesc.Count = 1;                         

    // Don't use multi-sampling.

    swapChainDesc.SampleDesc.Quality = 0;

    swapChainDesc.BufferUsage =

    DXGI_USAGE_RENDER_TARGET_OUTPUT;

    swapChainDesc.BufferCount = 2;                              

    // Use double buffering to minimize latency.

    swapChainDesc.Scaling =

    DXGI_SCALING_NONE;

    swapChainDesc.SwapEffect =

    DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.

    I have tried to disable the 3D mode by creating the swapchain again with the stero mode to false but it does not set the display back to 2D. Is this by design?

    Can somebody help?

    Thanks!

    Wednesday, September 26, 2012 4:02 AM