none
Unable to detect nor install USB 3 Driver RRS feed

  • Question

  • Hi,

    I installed WE8S using IBW 64 bit. USB3 wasn't detected.

    I reinstall the system using win 8 64 bit enterprise and USB3 detected ok.

    I ran TAP, import to ICE, installed again and didn't helped.

    I took the file Microsoft-Windows-Embedded-INF-usbhub3~31bf3856ad364e35~amd64~~6.2.9200.16384.cab from the following path: C:\Windows Embedded Catalog\6.2\9200.16384\amd64\modules\Driver

    I ran DISM /online /add-package /packagepath:e:Microsoft-Windows-Embedded-INF-usbhub3~31bf3856ad364e35~amd64~~6.2.9200.16384.cab

    It reported 100% installed succesfully.

    Reboot, check the Device Manager still no USB3 

    Intel's web site said: no special driver is needed as it is included in Windows 8 Installation it self.

    Any Idea?

    Thanks in advance,

    Avi Wertheimer

    Thursday, October 10, 2013 3:48 PM

All replies

  • One nore trial with no solution.

    I add also the package "Microsoft-Windows-Embedded-INF-usbxhci~31bf3856ad364e35~amd64~~6.2.9200.16384.cab"

    but it didn't helped

    Need help...

    Thanks

    Avi

    Thursday, October 10, 2013 4:39 PM
  • Try putting in all the drivers in the configuration file. If the driver then loads, then you know you have a missing support driver.

    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Friday, October 11, 2013 1:36 PM
    Moderator
  • I add all drivers, Features and updates manually. Still not working.

    More background description:

    When connecting device to the USB port and getting in to the BIOS, the device is detected (keyboard for example, works fine when in BIOS)

    If booting from Win PE, the port is still responding (keyboard and mouse for example works and can use them to install OS via IBW for example)

    But, when WE8 OS installed and boots, the Keyboad and mouse stop responding as OS loaded (keyboard and mouse lights off)

    moving the keyboard and mouse to other USB ports (only USB 2.0 ports), they came to a live.

    Workaround: (changing port to USB 2.0 only)

    When in BIOS - I Disabled the function "HS Port Switchable" (it is in Chipset->PCH-IO Configuration-> USB Configuration) and the USB Port start responding AS USB 2.0 (As explaind in the BIOS help)

    But this workaround is not good (I need USB 3.0 Support)

    What there is in Windows 8 Enterprise that discovers and installs the USB 3.0 Driver and not present in IBW?

    Thank for helping,

    Avi Wertheimer

    Saturday, October 12, 2013 9:16 AM
  • The Embedded Core doesn't support USB 3.0. For WinPE, you have to inject the USB 3.0 device driver in the install.wim package. Since you don't have a separate driver, you will have to use USB 2.0.


    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Saturday, October 12, 2013 2:46 PM
    Moderator
  • Win PE used only for service, so no need for USB 3.0 for it.

    But for the Windows Embedded 8 it is needed.

    More Info:

    The pmq from Windows 8 Enterprise OS installed on that hardware shows the USB3/xHCI Drivers and when importing it to Cofiguration

    Any other thing can be done?

    Yours,

    Avi Wertheimer

    Saturday, October 12, 2013 7:25 PM
  • Hm.. I'm not experienced with USB 3.0 yet but you could reinstall Windows 8 Enterprise and than gather all installed Drivers (or look in properties, Driver Details) which Driver is responsable for XHCI (I would guess it's USBXHCI.sys or something) than you can search for the file(s) (usbxhci.sys?) in ICE.

    Should work in some Kind of way.

    Or you gather the Drivers (including General Microsoft Drivers) with double Driver or something similar (drivergrabber) and Import all inf files with ICE to the target answer-file. This is not a nice and clean way but should do the trick. after this you can begin with optimization. (but you have General Support)

    With new Hardware, maybe there is some bug within the bios/uefi Firmware and some updates is provided by the manufacturer.


    Windows Embedded Developer and Scripting Guy //Germany (http://www.wesnext.com)


    • Edited by KNARZ Sunday, October 13, 2013 10:29 PM
    Sunday, October 13, 2013 10:26 PM
  • Thank you for all, It tooks some amount of hours, but at last, I found a solution works for me.

    Here is the end of the story:

    To start the story from its end, I would like to share with you that lake of digital signature  was the reason for the installation to fail in first place.

    The solution is:

    After proper installation of WE8, verifying both usbhub3 and usbxhci drivers are present, reboot with “Driver Signature enforcement” feature disabled and install the drivers manually.

    Full Description of recommended installation process.

    Install OS with IBW or ICE

    Add both drivers` xhci and usbhub3

    After rebooting with “Driver Signature enforcement” feature disabled, locate the drivers and run the following commands

    Pnputil –I –a Driverpath\usbhub3.inf

    Pnputil –I –a Driverpath\usbxhci.inf

    And I will take this opportunity to express my Special appreciation to you Sean Liming for your Great/Great books you published and for your tremendous support in this web site.

    Avi Wertheimer

    WE Struggeler (-:

    Israel.

     

    • Proposed as answer by P 'Bunny' E Wednesday, March 26, 2014 12:03 PM
    Monday, October 14, 2013 5:50 AM
  • Hi guys,

    I have a similar problem on Intel core i3 celeron + Intel QM77 PCH chipset, and when I install Win 8 pro it is all USB2.0 / USB3.0 work. And under WS8E, all USB2.0 / USB3.0 still work under boot list, but when entered WS8E found USB2.0 work but USB3.0 not work.

    I have tried original standard USB drivers (Windows internal), tried USB3.0 drivers installed in normal mode, tried USB3.0 drivers installed in "Advanced Startup with disabled digital signature mode", but still failed.

    At Device Manager, all USB3.0 drivers seem no exclamation/question mark, showing "Standard Enhanced PCI to USB Host Controller".

    Do you guys come across this before? And do you have any suggestion for me to solve this?

    Thanks you guys very much in advance~!
    Thursday, March 20, 2014 4:13 AM
  • I just ran into this one for a customer project. Try add INF-usbhub3 driver module. Also try adding INF-usb, INF-usbcir, and INF-usbhci.

    Looks like PMQ import is not perfect.


    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Thursday, March 20, 2014 5:35 AM
    Moderator
  • I have luckily solved this. Thanks again Avi Wertheimer for the clues.

    I have done the below and now succedded all USB2.0 / 3.0 usable in WS8E in any boot up Windows.
    (1) download the correct USB3.0 driver (include USB.inf & XHCI.inf)
    (2) use advanced startup "disable digital signature"
    (3) Administrator privilege to run "command prompt"
    (4) PNPUTIL -i -a "driver path/ xxx.inf"
    (5) Then in Device Manager will find a few more USB / enhanced USB drivers, then you will succeed.

    Good luck guys.

    Thursday, March 20, 2014 10:42 AM