none
SQL SERVER 2014 Install issue

    Question

  • Hello,

    I tries to install SQL SERVER 2014 EXPRESS on a HP LAPTOP on WINDOWS 10 HOME. 

    The setup fails at "RsFxConfiguration service rsfx0310". The error message is the following

    ------

    (01) 2016-12-04 19:01:17 SQLEngine: : Checking Engine checkpoint 'InstallRsFxDriver'
    (01) 2016-12-04 19:01:17 SQLEngine: --RsFxConfiguration: RsFxConfiguration: Install
    (01) 2016-12-04 19:01:17 Slp: Sco: Attempting to open SC Manager
    (01) 2016-12-04 19:01:17 Slp: Sco: Attempting to open service handle for service RsFx0310
    (01) 2016-12-04 19:01:17 Slp: Sco: Attempting to close SC Manager
    (01) 2016-12-04 19:01:17 SQLEngine: --RsFxConfiguration: Service RsFx0310 does not exist, executing install steps
    (01) 2016-12-04 19:01:17 Slp: Sco: Attempting to create base registry key HKEY_LOCAL_MACHINE, machine 
    (01) 2016-12-04 19:01:17 Slp: Sco: Attempting to open registry subkey SYSTEM\CurrentControlSet\Services\FltMgr
    (01) 2016-12-04 19:01:17 Slp: Prompting user if they want to retry this action due to the following failure:
    (01) 2016-12-04 19:01:17 Slp: ----------------------------------------
    (01) 2016-12-04 19:01:17 Slp: The following is an exception stack listing the exceptions in outermost to innermost order
    (01) 2016-12-04 19:01:17 Slp: Inner exceptions are being indented
    (01) 2016-12-04 19:01:17 Slp: 
    (01) 2016-12-04 19:01:17 Slp: Exception type: Microsoft.SqlServer.Configuration.Sco.ScoException
    (01) 2016-12-04 19:01:17 Slp:     Message: 
    (01) 2016-12-04 19:01:17 Slp:         Tentative d'exécution d'une opération non autorisée.
    (01) 2016-12-04 19:01:17 Slp:     HResult : 0x84bb0001
    (01) 2016-12-04 19:01:17 Slp:         FacilityCode : 1211 (4bb)
    (01) 2016-12-04 19:01:17 Slp:         ErrorCode : 1 (0001)
    (01) 2016-12-04 19:01:17 Slp:     Data: 
    (01) 2016-12-04 19:01:17 Slp:       WatsonData = HKEY_LOCAL_MACHINE@SYSTEM\CurrentControlSet\Services\FltMgr
    (01) 2016-12-04 19:01:17 Slp:       DisableRetry = true
    (01) 2016-12-04 19:01:17 Slp:     Inner exception type: System.UnauthorizedAccessException
    (01) 2016-12-04 19:01:17 Slp:         Message: 
    (01) 2016-12-04 19:01:17 Slp:                 Tentative d'exécution d'une opération non autorisée.
    (01) 2016-12-04 19:01:17 Slp:         HResult : 0x80070005
    (01) 2016-12-04 19:01:17 Slp:         Stack: 
    (01) 2016-12-04 19:01:17 Slp:                 à Microsoft.SqlServer.Configuration.Sco.InternalRegistryKey.OpenSubKey(String subkey, RegistryAccess requestedAccess)
    (01) 2016-12-04 19:01:17 Slp:

    ----------------------------------------

    It seems that there is an unauthorized access to the registry key SYSTEM\CurrentControlSet\Services\FltMgr

    I tries to change access control of this registry key using regedit. And that's true, I cannot do it, I have system access error.  Even I am administrator user.

    Can you help me?

    Thanks.

    Sunday, December 4, 2016 11:40 PM

Answers

All replies

  • Hello,

    The operating system may be corrupted or have some missing files. Please confirm this is the case using the System file Checker tool as explained on the following article:

    https://support.microsoft.com/en-us/kb/929833

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Monday, December 5, 2016 5:39 AM
    Moderator
  • Hi, when we used to hit this issue in older versions of SQL Server setup, you could run rsfx.msi manually from the install media to install the required files, then run the installer again to get past this. The msi is located in the setup media under the <architecture>\Setup folder (ex: X64\Setup\rsfx.msi). I haven't tried it in ages, but you could give that a shot if you're stuck.

    Thanks,
    Sam Lester (MSFT)


    http://blogs.msdn.com/samlester

    Twitter - @SQLSamLester

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you. This can be beneficial to other community members reading the thread.

    Monday, December 5, 2016 5:57 AM
    Moderator
  • Thanks a lot Alberto and Sam,

    SFC founds several errors, so I have decided to restore my PC to original system. Then I install first SQL server and it works.


    Tuesday, December 6, 2016 9:50 PM
  • Hello,

    I have the same problem with installing SQL Server 2016 on Windows 10 home, unauthorized operation on fltmgr.
    The SFC tool didn't find any errors.
    I tried to install it with the hidden administrator account, and changed the account to NT AUTHORITY/SYSTEM in the server configuration. I also tried to install it from a different directory, but still got the same problem.

    In another thread someone suggested that a Windows 10 component prevents the write operation to fltmgr. But he didn't know which component. He suggested to install it in safe mode, but that isn't possible for SQL Server.

    Do you know what I can do, I really need to install SQL Server.

    Thank you in advance.

    Best regards,

    Thijs

    Wednesday, April 26, 2017 9:40 AM
  • Hello Alberto,

    I have used System file Checker tool and it came out saying that there was no issue found.

    I have tried to take ownership of SYSTEM\CurrentControlSet\Services\FltMgr as admin however I have always got Access denied message. Even as an admin I cannot do anything about this registry key which is blocking the installation.

    Would you be able to help?

    Kind regards,

    Martin

    Sunday, February 4, 2018 11:22 AM