none
Uncomment code auto insert tab

    Question

  • Dear Team, 

    I encountered problem with Visual Studio 2015. I have tried to change few setting under the Tools. but it doesnt' help

    1) When i comment few lines and everything looks fine as shown below

    2) After that i select the same multiple line and uncomment and those few highlighter line actually shifted to right by a 'tab' or indent width. Which i don't want. Can i have the code remain at its position and remove the comment only..

    Tuesday, August 16, 2016 1:27 AM

Answers

  • Hi limcheehang,

    Which version of Visual Studio 2015 do you use?

    According to your screenshot, I create a VB project and add some code which is similar with yours in my Visual Studio Enterprise 2015 with Update 3. Then I comment some lines and then uncomment these lines, after I select the lines and uncomment and those code remain at its position and remove the comment only, which is working correctly.

    Please check whether your Visual Studio 2015 has installed the latest update and please check whether your Visual Studio installed any other third part extensions which effect the action of your Visual Studio. You can run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.

    In addition, since you have changed some settings for your Visual Studio, I suggest you reset all settings through Tools -> Import and Export settings -> Reset all settings to let your Visual Studio running under default settings.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, August 17, 2016 1:14 AM
    Moderator

All replies

  • Dear Team, 

    I encountered problem with Visual Studio 2015. I have tried to change few setting under the Tools. but it doesnt' help

    1) When i comment few lines and everything looks fine as shown below

    2) After that i select the same multiple line and uncomment and those few highlighter line actually shifted to right by a 'tab' or indent width. Which i don't want. Can i have the code remain at its position and remove the comment only..

    I don't have an answer here - but I do have this to offer:

    While it's true that there are many things in this life to really be concerned about, that's not one of them...


    Some people succeed because they were destined to, but most people succeed because they were determined to.

    Tuesday, August 16, 2016 1:46 AM
  • Hi limcheehang,

    Which version of Visual Studio 2015 do you use?

    According to your screenshot, I create a VB project and add some code which is similar with yours in my Visual Studio Enterprise 2015 with Update 3. Then I comment some lines and then uncomment these lines, after I select the lines and uncomment and those code remain at its position and remove the comment only, which is working correctly.

    Please check whether your Visual Studio 2015 has installed the latest update and please check whether your Visual Studio installed any other third part extensions which effect the action of your Visual Studio. You can run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.

    In addition, since you have changed some settings for your Visual Studio, I suggest you reset all settings through Tools -> Import and Export settings -> Reset all settings to let your Visual Studio running under default settings.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, August 17, 2016 1:14 AM
    Moderator