locked
People Search Results disable/hide managed property in refinement panel RRS feed

  • Question

  • When doing a people search in the people refinement panel there's the Job Title refiner.  When I click on "show more" the panel expands but now it also includes a custom property named "Employee Id" with the values of employee id's.  I don't want the employee id's to show.

    In Central Admin->Manage User Properties-> edit "EmployeeId".  Under Search Settings Indexed is checked.

    In Central Admin->Search Service Application->Metadata Property Mappings.  Has Multiple Values is checked, Mappings to crawled properites has People:EmployeeId(Text) and nothing else is checked.

    Not sure how to turn this off or disable it.  Any ideas?

    Monday, February 28, 2011 9:52 PM

Answers

All replies

  • haha i feel dumb right now...

    Edit the people refinement panel->Refinement->Filter Category Definition.  Click on elipse to edit the xml. 

    Remove the following:

       <Category    Title="Managed Metadata Columns"    Description="Managed metadata of the documents"    Type="Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator"    MetadataThreshold="3"    NumberOfFiltersToDisplay="3"    MaxNumberOfFilters="50"        ShowMoreLink="True"    MappedProperty="ows_MetadataFacetInfo"    MoreLinkText="show more"        LessLinkText="show fewer"/>

    MAKE SURE YOU UNCHECK "Use Default Configuration".  I didn't do this last time ;]

    • Proposed as answer by MaartenSundman Monday, February 28, 2011 10:20 PM
    Monday, February 28, 2011 9:59 PM
  • Are you sure? According to http://blogs.msdn.com/b/spnext/archive/2010/08/09/customising-sharepoint-2010-search-refiners.aspx, for managed property such as your EmployeeID, the type should be Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator instead of Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator.

    • Marked as answer by GuYuming Sunday, March 20, 2011 12:19 PM
    Monday, March 7, 2011 8:30 AM