locked
Getting "Exception from HRESULT: 0x80131904" error message RRS feed

  • Question

  • Hi,

    I intermitently received the "Exception from HRESULT: 0x80131904" error message on my Sharepoint site.  For example, it pops up when I try to add a folder in a document library.

    What could be my problem?

    Thanks!

    Benoit

    Tuesday, November 2, 2010 2:59 PM

Answers

All replies

  • Hi,

    check the ULS logs for more info(use the CorrelationID).

    Make sure that your Content Database in SQL is not full.

    Cheers,


    Daniel Bugday

    Web: SharePoint Forum
    Blog: SharePoint By Bugday
    Twitter: Follow me on Twitter
    Technet: My Ask The Exert Area On Technet

    • Marked as answer by Seven M Tuesday, February 1, 2011 5:09 AM
    Tuesday, November 2, 2010 4:19 PM
  • Hi Daniel,

    The content DB was full.  Sharepoint was installed on MSSQL Express, which is limited to 4G.  I migrate it to regular version and now everything is fine.

    Thanks!

     

    • Marked as answer by Benoit1 Wednesday, November 3, 2010 1:24 PM
    Wednesday, November 3, 2010 1:24 PM
  • Hi Daniel,

    Please help me.  I am trying to update/delete/modify content on my site, but keep on receiving the following message:

    Exception from HRESULT: 0x80131904

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 0c3f4488-d2f2-4851-ade4-d2ba9d1101d0

     

    I am a novice end user, and have no idea what a ULS is or how to access the content database as you instructed a previous inquirer. 

    Can you let me know step by step how to go about fixing this issue?

    Hope to hear from you soon.

    - JMK


    JMK
    Monday, February 14, 2011 6:45 PM
  • I am novice too...!!

    This problem also happens to me .. is because they happened to run out of disk space which houses the log and database .. check the space and the size of the database.

    Thursday, July 7, 2011 11:40 PM
  • this is also generated by an invalid filter value. I got this when i was trying to setup a value for my filtered view and i was using "closed" as the value for my workflow status filter option where it should have been an integer value of something like "27". Crazy stupid method they used but here's the post where i resolved my issue:

    http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/f5de7947-f49b-420a-b8d8-d44ad6b7769f

    See this post on how to find the custom integer value for your custom workflow status value.

    Wednesday, July 13, 2011 8:47 PM
  • Hi,

    I had the same error message "Exception from HRESULT: 0x80131904" when adding or editing documents in Sharepoint.

    This post and the replies got me on track troubleshooting the SQL Server.

    In my case the problem was a full drive due to undeleted back-up files.
    Clearing the drive from old back-ups and changing the back-up job solved it for me.

    /Thanks

    Tuesday, August 23, 2011 8:25 AM
  • Hi,

     

    This can also be related to the service running the application pool for "Sharepoint Central Administration" not having sufficient rights in the database.

    If you have changed the service account check windows application log and look for something like this:

     

    ----

    Event ID: 5214

    Source: SharepointFoundation

    Task Category: Database

     

    Insufficient SQL database permissions for user 'Name: DOMAIN\sharepointuser SID: S-1-5-21-132112313-456456-45645646-12101 ImpersonationLevel: Impersonation' in database 'SharePoint_AdminContent_79933b0f-d4ec-45fb-94ec-5754767dc132' on SQL Server instance 'SERVERNAME\SQLExpress'. Additional error information from SQL Server is included below.

     

    The EXECUTE permission was denied on the object 'proc_EnumLists', database 'SharePoint_AdminContent_555555-3333-4444-6666-1111111111', schema 'dbo'.

    --

     

    And check the accounts db map settings in management studio. I had to give it dbo rights.

     

    //JimiSweden

    www.newsweb.se

     

    • Proposed as answer by Vanitha Bhat Friday, April 26, 2013 7:20 AM
    Thursday, September 8, 2011 12:01 PM
  • I recently started receiving this error out of the blue. It was paired with some other bugs that I later realized were unrelated.

    The error would pop up in the Application Log on the FWS and the SQL server. It would happen from 2 different methods both of which were trying to accomplish the same result.

    1. Updating a field using a custom InfoPath (Browser Rendered) form for a SP list. The column was populated from a related list. After choosing the correct value and saving the form the error would appear. The end user was also presented with the error message below.

    "InfoPath Exception from HRESULT: 0x80131904"

    2. The second method that would spark this error was a workflow trying to update the same field in the same list with the same value. The workflow would subsequently fail.

    After several trips down the wrong roads I stumbled upon the issue. I had indexed the column I was trying to update and the index was corrupt/incomplete. Once I removed the index the issue was resolved. I am going to rebuild the index after hours to see if it was indead corruption and if a rebuild will also fix it.

    Hope this helps someone else.

    Monday, October 24, 2011 9:38 PM
  • Alex - THANK YOU THANK YOU THANK YOU...

    This was my problem as well.  I had a corrupted index.  Everyone kept saying, the DB is out of space, but this was clearly not my issue...  Deleting the corrupt index fixed this issue!!!

    Tuesday, October 30, 2012 9:30 PM
  • Hi Daniel, 

    This helped a lot. Thanks a ton.

    Wednesday, December 5, 2012 5:54 AM
  • Thank a lot Jimi.. This fixed my issue with retrieving List from Central Admin.
    Friday, April 26, 2013 7:21 AM
  • Dears All

    I have this error message when tried to create the site collection, the error message as below

    <nativehr> 0X80131904 </nativehr> <nativestack>< /nativestack>

    Note: The Data Base content for the web application is changed to different Data Base because I need the new one because it is for production portal and including all site collections, List, style sheet, java script library....etc, so I need it to restore the application in local environment.

    So can some one help me ASAP.

    Friday, March 14, 2014 1:17 AM
  • MohFarhan,

    You need to stop asking a new unrelated question on questions that have been answered for years.

    Find the proper forum and ask a new question, and then you will get a response :)

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer.
    My Blog: Unlock PowerShell
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ('6F6C646B61726C40686F746D61696C2E636F6D'-split'(?<=\G.{2})'|%{if($_){[char][int]"0x$_"}})

    Wednesday, April 23, 2014 8:07 PM
  • Hi
     i don't know how to do that, i have that problem now...

    can someone help me with that?

    Thanks
    Thursday, May 8, 2014 5:35 PM
  • Do you mean the search index file?  We rely too heavily on search for this to be deleted.
    Thursday, September 11, 2014 2:32 PM