none
Problem installing update for Azure Data Lake and Stream Analytic Tools (version 2.3.4000.4)

    Question

  • Hello. I installed Visual Studio Professional 2017 version 15.8.2. When I launch VS, a notification display to update Azure Data Lake and Stream Analytic Tools (version 2.3.4000.4). I download the update from within VS and the update is scheduled to run after VS is closed. I quit VS and VS Installer began executing. But the update is not installed and the message error is:

    Extension cannot be installed to the following products due to missing prerequisites:

          Microsoft Visual Studio Professional 2017

                Identifier: Microsoft.Visual Studio.Component.Common.Azure.Tools

                Name:      Common Azure Tools

                Version:     (1.8, 2.0)

                Error:        The prerequisite version specified does not match the version installed

    Any help will be welcome. Thanks.

    Saturday, September 1, 2018 3:26 AM

Answers

All replies

  • I am having the same problem.

    Marius

    Tuesday, September 4, 2018 3:54 AM
  • Me too facing the same issue. Any help ?
    Wednesday, September 5, 2018 12:51 PM
  • Me Too

    05.09.2018 19:03:10 - Für die Erweiterung wird ein Upgrade von Version 2.3.3000.5 durchgeführt.
    05.09.2018 19:03:13 - Die Erweiterung kann für die folgenden Produkte aufgrund fehlender erforderlicher Komponenten nicht installiert werden:
    05.09.2018 19:03:13 - Microsoft Visual Studio Professional 2017
    05.09.2018 19:03:13 - -------------------------------------------------------
    05.09.2018 19:03:13 - Identifier   : Microsoft.VisualStudio.Component.Common.Azure.Tools
    05.09.2018 19:03:13 - Name         : Common Azure Tools
    05.09.2018 19:03:13 - Version      : [1.8,2.0)
    05.09.2018 19:03:13 - Error        : Die angegebene erforderliche Version entspricht nicht der installierten Version.
    05.09.2018 19:03:13 - 
    05.09.2018 19:03:13 - System.InvalidOperationException: No modifications could be applied.
       at VSIXInstaller.MultipleChangePage..ctor(ExtensionData data)
       at VSIXInstaller.LoadingPage.<>c__DisplayClass15_1.<OnLoaded>b__2()

    Wednesday, September 5, 2018 5:08 PM
  • Anyone got the workaround for this issue? I've been experiencing this issue for at least 3 weeks, now. :(
    Wednesday, September 5, 2018 10:34 PM
  • Hi Jose, 

    A new version, 2.3.4000.5 is updated to fix this. Please try from Tools -> Extension and Updates. Thanks! 

    Friday, September 7, 2018 9:44 AM